Microsoft Azure Computer Vision OCR activity not giving the same quality output as Azure Computer Vision Image Recognition website

Hi, I’m using the UiPath Studio Community 2019.5.0 Edition and this is a question regarding the quality of output I’m getting from the Microsoft Azure Computer Vision OCR activity in UiPath. I have a project that requires reading text (both printed and handwritten) from jpeg images of forms that have been filled out by hand (basically photographs of the forms).

While testing it on the Azure website (Computer Vision | Microsoft Azure), I’ve gotten almost 90% of all printed and handwritten text accurately outputted. Since UiPath has the Microsoft Azure Computer Vision OCR, I tested it but was surprised to see that the output was of poor quality… in many cases not even 10% of the handwritten text got outputted correctly or at all. I was just wondering if there is a reason for this, and if I was doing anything wrong. I wish I could provide samples of the outputs but the forms are confidential, so am not able to.

I’ve checked all the other Cloud Vision OCR activities as well. ABBY was marginally better, but I am primarily wondering why the Azure website’s output and the UiPath activity’s output could have such a big difference in quality.

Has anyone else faced this?

Hi @DavisUI,
Are you sure that you provided correct APIkey for this activity?

Hi @Pablito,

Thanks a lot for your reply. Yes, I first tried with the free API and Endpoint that i got from Microsoft (without creating an account on Azure). I then created an account (the free for a month or so one), created a project in the Portal and got the APIs and Endpoints from there too and tried with those as well. But the results are same. Nothing close to what I get on the Azure website.

I must also mention that we tried the “Microsoft Vision OCR” activity as well… all the images got moved to the Failed folder without any json file outputs. The Output log also showed “Image download.jpg processing status: Processing status is failed on Vision API. Details: Resource Not Found;Successfully copied the image to” (Davis note: the failure folder name was here)

On Python as well, it throws the error as “Resource not found”

Wondering if only APIs we get after paying for the Azure services work…

Very strange. I assume that you’ve also tried to experiment with Scale and Language attributes. Please also be sure that nothing is blocking UiPath Studio from internet as for this activity it is using cloud for sending samples to decode image.

Yes, @Pablito, we’ve tried with languages and scales too. Yeah, its very strange. We will be trying it out with an API we have paid for and are hoping that will give a good result. Will keep the Forum posted about the progress, so it’ll useful in case anyone faces the same issue.

1 Like

Hi @Pablito,

Just checking, do you know why the error in the image attached is occurring for the Read Handwritten Text activity? I have attached a screenshot that shows the activities and the error. I have entered the API and Endpoint in the Vision Scope activity.

but seem to be getting this error. I’ve tried using Azure with this but am not sure how to use it sensibly in the flow for this (and haven’t been able to find a good place that describes how these activities are used)…

Can you show screenshot with arguments set for Microsoft Vision Scope and Read Handwritten Text. Of course please remove any sensitive data.

Thank you, Pablito, Please find attached screenshots of the arguments in bothArguments

Hmmm seems that activity can’t get any result from the image and return error. Can you try to test with other image?


I’m also facing same issue which has been mention by @DavisUI,


As your previous suggestion, I have used different images but still facing this problem. Can you please help me for this issue?


Guys please check this topic. I remind myself that there was similar issue couple weeks ago. The problem was related to wrong URL address for the service.

Hi @Pablito, apologies for the super later reply and thank you for your reply. It works for some images, as before, but images that give a good result on the Azure website give a bad one on the UiPath Azure activity.

I’ve been trying it again with a paid API key but now its showing some errors. Will keep the forum updated if there are any positive results.

1 Like

Hi @DavisUI it sounds like I’m following the same path you took, by creating a service in Azure and then using UiPath’s Azure Computer Vision OCR. I’m getting the same error and have tried changing the Endpoint to what I see in the Azure API testing site.

How were you able to get it to work?

Found . Fix my problem with being able to use Microsoft Azure Computer Vision Computer Vision | Microsoft Azure

the end point which I have generated for my Computer Vision service is not working for Microsoft azure computer OCR but same end points and api key works for read handwritten activity. can you suggest solution if you have faced the same?

Dear Pblito,

the end point and api key I generated from microsoft azure service is not working for microsoft azure computer azure OCR activity but same work for readhandwitring activity.

Also the free key which we can generate Create Your Azure Free Account Today | Microsoft Azure works for both MSAurecomputerOCR and readhandwriting but paid service API is not working… can you pls help or advise?

Have you tried the ‘read activity’? I believe that activity is the same API activity for using Microsoft Azure Computer Vision OCR,

you mean read handwriting activity? Yes, it works but unfortunately I cant use it digitize document which expect OCR activity.

also can you please share the endpath one should use ? I am sensing I should be adding something to the end path which is flashed in azure.