Message: Cannot create unknown type

studio

#1

Good day

I am getting the following error when I try to run my workflow

Message: Cannot create unknown type ‘{http://schemas.microsoft.com/netfx/2009/xaml/activities}Variable({http://schemas.uipath.com/workflow/activities}DatabaseConnection)’.

Source: System.Xaml

Exception Type: XamlObjectWriterException

This occurs when trying to create and run a Database connection, when creating the connection the test connection is successful.

Any help would be appreciated

Massimo


Cannot create unknown type '{http://schemas.uipath.com/workflow/activities}Continue'
Execution error : System.Xaml.XamlObjectWriterException: Cannot create unknown type '{http://schemas.uipath.com/workflow/activities}ReadRange
Orchestrator Error: ClearSheetData
#2

hello…

oh, have you installed all the packages (use “ctrl+P”) ?

let us know.


#3

Hi - did you resolve this issue? I have the same problem. The process works fine on one bot but fails with this error on the other bot. I guess it is a installation package dependency problem but have not yet been able to identify what the issue is.


#4

Unfortunately not.


#5

Most probably - try to identify which activity throws the error and reinstall the package that it comes from (it should also reinstall the needed dependencies in most cases).
If you’ll be unsure which one is it, post the name of it and someone here will definitely be able to identify it.


#6

Hi again. I solved my issue. I was examining the differences between a bot machine that the process worked ok on and the ther that it was failing with this error. I saw that the failing bot did not have these directories

C:\Users<YOUR USER>\AppData\Local\UiPath\Activities\UiPath.Excel.Activities.2.0.6382.14545
C:\Users<YOUR USER>\AppData\Local\UiPath\Activities\CsvHelper.2.13.5.0

Once I copied these across the process worked ok.

I concluded that the packages that your processes are dependant on at runtime must exist in this AppData directory structure. The primary difference between my servers were one had Studio installed (and therefore had installed all of the packages as part of the development process) and the other was a robot only and had never had any dependant packages installed. It is still not 100% clear to me as to the best process for deploying these to a robot machine as copy paste of files seems a bit low tech! But at least it works now!


Cannot create unknown type
#7

THANKS!!!
I did examine the UiPath folder and found that they are different!
And I tried with some another machine who had the same folders and there it worked!


#8

Hi @andrzej.kniola @Peter_Lacken
When I am using the script through command prompt I am getting the same issue.
I have the above packages in folder,
Can you please help.
Thanks


#9

What Studio\Robot version are you using?
What is the version of the excel pckage used to develop the workflow?


#10

Hi @Gabriel_Tatu
Uipth studio version 2018.2.3
and excel package version UiPath.Excel.Activities.2.4.6666.26225
Simple workflow is working but the workflow with database connection is not working(mysql database)


#11

Paste here the exact error you are seeing please.


#12

Please I need your help.
I have the same problem, but with this solution not execute my robot.
I copied the files but nothing.
I’m use the Uipath Studio 2016.2.6192 and Uipath.Excel.Activities.2.3.6682.26635


#13

Tell me your exact problem please and steps to reproduce.


#14

@Gabriel_Tatu Hi,
I’m having the same problem.
I have one server with Studio and one test server without Studio.
I’m using 2018.2.3 and the package that isn’t working on the test server is SB.OutlookMail.Activites 1.0.0.0 .
I tried to put the package in the AppData Activites folder on the test server, but I still get the error: Cannot create unknown type ‘{clr-namespace:Santan.OutlookMail;assembly=OutlookMail}sendOutlookMailWithImage’.
Any suggestions?


#15

I am having the same problem. While running my workflow getting the below error message-
Main has thrown an exception
Source: System.Xaml
Message: Cannot create unknown type ‘{http://schemas.microsoft.com/workflow/2012/07/xaml/activities}BuildDictionary({http://schemas.microsoft.com/winfx/2006/xaml}String, {http://schemas.microsoft.com/winfx/2006/xaml}String)’.
Exception Type: XamlObjectWriterException

I tried to update the packages as well, but getting the below error pop up-
" Unable to resolve dependency. Uipath. version>=1.1.0"

I have used database connection , dictionary in my workflow.

Uipath version: 2018.2.4

Please suggest.


#16

We have a similar problem with a custom activity. The custom activity was manually downloaded from https://gallery.uipath.com/packages and stored locally in the UiPath Studio environment. Manage Package (Ctrl+P) was used to install the activity in UiPath Studio. In one process the custom activity was then used and on the computer with the UiPath Studio the custom activity can be executed without problems. The process was then deployed to the Orchestrator. However, this process cannot then be executed on other robots. The error message is execution error : “System.Exception: Cannot create unknown type ‘{clr-namespace:UiPath_Custom;assembly=customactivity01}MoveDirectory’”. We have the problem independent of the Custom Activity used.


#17

is that custom activity package present on orchestrator activities feed?


#18

update all package


#19

How is the custom activity to get on the orchestrator activities feed? Does the file have to be copied there manually?


#20

yes, you ll put the nupkg on the feed (next to the rest of the uipath activities) and the robot will know how to get it