Missing Activities in UiRobot.exe


I see lots of posts here about missing activities and dependencies with no clear solution, for example:

My scenario is:

Just upgraded from 2018.1 to 2018.2.3 Enterprise license

Do not use Orchestrator

We use the task scheduler to launch robots from the command line (like “C:\Program Files (x86)\UiPath\Studio\UiRobot.exe” -file “path to xaml file”)

All the robots run fine from Studio

All packages in studio are installed and updated (plus re-installed to see if it fixes anything)

When UiRobot.exe tries to start the workflow we see lots of errors like this:

Message: Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities 2}GetSecureCredential’.

If I click Publish in studio it seems to fix the issue, even though I don’t understand what this does:
If I delete the package created by clicking publish the robot still runs fine so what is the package for?
I never used to click publish and everything still worked fine before, why is it required now?
If I make changes to the workflow do I need to publish again (since it seems the package is not used)?

It’s not clear to me why I now get this error and why clicking Publish fixes it. Does anyone have a clear explanation what causes this and how things are set up with respect to activities and packages.


1 Like

After more investigation it seems that if you don’t click publish then the project.json file is missing the dependencies section. After clicking publish it is populated as shown below:

“name”: “TEST2”,
“description”: “Blank Project”,
“main”: “Main.xaml”,
“dependencies”: {
“Microsoft.Activities”: “”,
“Microsoft.Activities.Extensions”: “”,
“UiPath.Cognitive.Activities”: “2.0.6716.19435”,
“UiPath.Core.Activities”: “18.2.6745.15248”,
“UiPath.Credentials.Activities”: “1.1.6479.13204”,
“UiPath.Database.Activities”: “1.1.6660.26865”,
“UiPath.Excel.Activities”: “2.3.6682.26635”,
“UiPath.Framework.Activities”: “1.0.5905.30080”,
“UiPath.Mail.Activities”: “1.1.6562.21018”,
“UiPath.PDF.Activities”: “1.1.6732.21973”,
“UiPath.WebAPI.Activities”: “1.1.6479.13209”
“excludedData”: [
“toolVersion”: “18.2”,
“projectVersion”: “1.0.6795.21880”,
“packOptions”: {},
“runtimeOptions”: {}

The package file that is created can safely be deleted as it has no effect on the robot from the command line. Since this is something that used to work is this something that changed in 2018.2.3? also why can’t the file be generated on saving the files instead of having to click publish?

Interesting thread. I just deleted my Dependencies section to see if it would be regenerated by publishing to Orchestrator, but it wasn’t.

Any thoughts on that? I want to ensure that my robot project’s dependency list is accurate and doesn’t contain stuff from a previous project I may have copy/pasted as a template.

No idea to be honest, I think the documentation is really lacking in these areas. If you read about Publishing it barely says what it does.

Hello everybody,

That’s really interesting.
At the moment, we I trying to solve the issue that only occures in UiPath-Robot UiRobot.exe.

We have created a .BAT file with c:\users\USERNAME\uipath\studio\uirobot.exe - file: x:\ …\ 2605.nupkg

If we run this o a PC which has UiPath Studio installed it isn’t a problem. The program runs successfully but if we start it on a different Pc which has only installed UIPath Robot, it throws the error:

An exceptiondetail … whose value is:

cannot create unknown type ’ ’

In the past there were several theards about it ( like bobpeers has shown)
I even asked UiPath to solve this issue but they just replied that this error occurs because of intern IT restrictions. We checked it but there are no restrictions.

What we want to do now is, to copy & paste the appdata\local\UiPath-Activities.
Like written down in this theard:

But it seems like the folder written in this older theard has changed:
Our activities are saved in following folder:

We are currently using the version 2018.4.5
Really hope this will solve the issue since it looks like UiPath doesn’t know why the error occurs. Will come back if we have any news. Thank you for this helpful post anyway. :smile:

Hi @Henne1992

I would have two guesses, just in case you haven’t solved it yet:

  • the Robot on the other machine doesn’t have access to the feeds of activity packages:
  • the Robot doesn’t have access to the folder where the nuget package is unzipped before running, and that would be here:

I’ve seen some threads on the Forum where the same error cannot create unknown type was due to the Robot user profile not having access to write in this location.

I hope these give you some ideas here :slight_smile:

i am having this prolem with running the robot using the batch file but when i run the batch file i get an error saying GET FEEDS TIME OUT…anyone who can help me with this please i will be grateful…it was working before but now it brings that error