Mail save attachments activity do not work

hello

Although I tried automatic saving of attached file, it seems that it can not operate.
When sending from iphone’s Gmai (ios)
The attached file is not saved.

However, when logging in to gmai and sending mail at the browser on the personal computer (mac)
The attached file is saved.

What is different?
Is there any mistake in setting UIPATH?

Automatic saving of attachments is not supported in UIPath.
You have to use Save Mail Attachments to save the email attachments explicitly.

thank you very much.

I used SavemailattachmentsActivity,

but UIpath did not save the attachiments(when I send from iphone to pc)

hello

I checked .NETframework virsion .

ver.NET Framework 4.7.2

hi there , what do you mean when you send from iphone to pc ! you mean when you send an email from your iphone outlook or any smtp ?

hello

yes, when I send an email from my iphone(gmail), to my pc(win10 thunderbird).

My pc(win10) can receive mail, but UIPATH can not save attachments.(PDF,jpeg)

my friend , it shouldn’t effected by such behaviour , can you share part of your code to check exactly what is the issue or screenshot for the issue , is there any throw or error !
or just not saving !, what is the get email activity you use ?

i tried to simulate your project by using IMAP and then check the subject by specific keyword such as test and then save attachment , i notice that when i send from my iphone the subject transform to upper letter to be Test and from windows pc it received just as it test , so it could be in the condition you need to check again , however i will attach the file you can try and let me know use your email and password .imap.xaml (9.4 KB)

Hi,
did you solve this problem in UI Path? If yes, how?

We are having troubles in downloading attachments from iOS emails as well in UI Path and using IMAP protocol. DO you have some news on that please?

Hi Hiroki,

I have exactly the same problem. Did you solve the issue or found a workaround?

Matus

Hi Hiroki,

I am also facing the same problem. I’m unable to save attachments sending from iphone(gmail). How did you resolve this issue?

I have confirmed this issue, it looks like the e-mail sent from iPhone Gmail app does not contain content disposition information and I suspect that is the cause.
More information about Content-Disposition is here


Let me avoid suggesting a specific app from my side, but using a different mail app is a possible workaround. Also if you have Outlook installed, Get Outlook Message Activity is a workaround.

I have escalated this issue to the developers, and we will see if this issue can be fixed. I would update this thread once ETA or fix is available, but please also understand that developers are juggling priority and this issue may not be prioritized based on whats on the table.

1 Like

I stumbled upon this issue now, it is still surviving :slight_smile:

Hi,
Definitely, I am also having the same issue…