Library with SOAP request - missing bindings

Hi!

I have problem with WSDL. I need to connect to https://wyszukiwarkaregontest.stat.gov.pl/wsBIR/wsdl/UslugaBIRzewnPubl-ver11-test.wsdl

When I created service and add needed variables i got this error:

image

As I read in instruction wsdl do not contains Header. How I should declare it to pass the right SOAP request?
This is properities from activity after installing wsdl service:

This is what I passed to request:
image

I tried with dictionary in that “Headers” properties but I get errors as well. Is anybody able to help me with that? :frowning:

This is working code in SOAP UI:

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:ns="http://CIS/BIR/PUBL/2014/07"> <soap:Header xmlns:wsa="http://www.w3.org/2005/08/addressing"> <wsa:To>https://wyszukiwarkaregontest.stat.gov.pl/wsBIR/UslugaBIRzewnPubl.svc</wsa:To> <wsa:Action>http://CIS/BIR/PUBL/2014/07/IUslugaBIRzewnPubl/Zaloguj</wsa:Action> </soap:Header> <soap:Body> <ns:Zaloguj> <ns:pKluczUzytkownika>workingCredentialKey</ns:pKluczUzytkownika> </ns:Zaloguj> </soap:Body> </soap:Envelope>

Or maybe that is not the case and this wsdl is not prepared the right way? When I tried Soap Request I got this error:

image