Library / Process run differences causing problems

I have created an .XAML file for a modified “Init All Settings” process and published it as part of a library. When I run a test routine that uses the “Init All Settings.XAML” as a workflow directly in the library it works as designed. When I run a separate robot process that uses the “Init All Settings” activity from the installed library the results are different.

The “Init All Settings” workflow / activity adds some column name checks the Data Tables created from the input configuration files.

Testing the “Init All Setting” workflow in the library project identifies all columns properly and any conditional logic referencing these columns works without issue.

Testing the “Init All Setting” activity in a project that has the library installed does not work correctly. Some of the issues are:

  1. only the first column is detected. Subsequent columns “Value”, “Description” are not reported
  2. explicit checks for important columns fail
  3. Sheet that do not have any data on the are processed. (They should be bypassed due to row count checking logic)

Here is a sample of the two runs side by side. The left side is run from the library project. The right side is from another project that makes use of the library. In both case the configuration file is exactly the same and it is fully qualified (to avoid issues with relative paths in libraries)

This is using UiPath Studio 2020.10.10.

The “Init All Settings” workflow / activity uses read range activity to read excel spreadsheet tabs into a data table. It may also use a “for each” activity to list all the column names in the data table.

It appears that the usage of datatable.columns functionality is inconsistent between the two projects.

Does anyone have any ideas as to what may be happening?

Thank you

The library code does the