Level3: Assignment1: Cannot find the UI element corresponding to this selector ( Navigate to work items)

I know there are a lot of posts regarding this issue but I am unable to make it work with the solutions delivered. Can you please help?

1 Like

When the Bot runs, is there the Browser Window already opened with ACME System Website? Usually this should work without any problem. Did you try to indicate the Window again?

Yes and am still having issues with the URL selectors for some reason.
I try to validate it over and over but still get issues although indicating the right way. This is another issue as well coming up

I am not really sure what shall I do?

mhm, that is strange. I just tried attach browser and navigate to a specific url with firefox and chrome and works without a problem.

@Palaniyappan do you have any idea how to solve that problem? Thanks!

1 Like

The URL in your Screenshot is “System1_URL+“work items/”+WorkItem_ID.toString”. But the URL is actually e.g. like “https://acme-test.uipath.com/work-items/557575” that means that you shoud add “/” and “-” to workitem. Thats how it should look like:

System1_URL + “/work-items/” + WorkItem_ID.ToString

Hi buddy
If we are trying to go and navaigate or do any activities inside the WORKITEMS window of the web page then may I know why the selector was replaced with wild card

And is that browser window brought to foreground of the screen when this activity is performed
That is very important

Cheers @Mod0091

thanks for your reply, but now am getting this error, can you help with it,please?

1 Like

Kindly reselect the whole tab or whole window as a element for this activity and try once executing buddy
@Hadeel_Al-Dowsh

I’ve tried multiple times and am getting selector errors in different places. Can you please run it on your Machine and let me know if it’s coming back with the same error messages.
Hadeel_Calculate_Security_Hash_Client.zip (1021.4 KB)

Hello there,
for the “Extract client information” workflow, the error is still coming up although am pretty sure that the selector is correct. any idea please?

Hey @Hadeel_Al-Dowsh, i think you didn’t catch all html elements when indicating the element. Try indicating with UI Explorer…you should get follwing informations:

<html app='chrome.exe' title='SHA1 online' />
<webctrl tag='SPAN' />

Thanks for your reply. Yes I have tried this too but the workflow is just sending back error messages and am not able to sort it out. I started to give up!

@Palaniyappan do you have any idea how to solve this?

Fine
Is the browser page is in foreground when this activity is performed
@Hadeel_Al-Dowsh

Yes the process is divided into workflows that are invoked in order. So yes, you login and navigate all the way thorough to reach this page in the process and I can see it opens but then the error message is thrown!

Fine
in which xaml we are getting failed
i will try to check with the zip files sent
@Hadeel_Al-Dowsh

Thank you. In the following workflows:

“Extract_Client_Information” and then the same in “SHA1_Get_Hash_Code”

Thank you in advance :slight_smile: