Getting error while executing uipath level 3 assignment1 at System1_Navigateto_WorkItems workflow and also it is showing as system error at initialization


#1

Error is like below:
System error at initialization: Cannot find the UI element corresponding to this selector: at Source: Click ‘BUTTON’

.

I tried changing selector but didn’t work.Can anyone suggest me what’s the issue.


#2

Hello @SUPRIYA123

Make sure you click activity is inside an “Attach Browser” activity!

You could also try using tab and enter to work as a workaround :slight_smile:

Regards,
Rishabh.


#3

Tried in that way.Getting error like this


#4

This looks almost identical to mine from this lesson but I used IE. Do you have the chrome plugin installed? Are you able to successfully click other items in chrome? Are you using SimulateClick or SendWindowMessages for the input method?


#5

In the title attribute, try using use value as ‘ACME System1 - *’


#6

I installed chrome plugin and i used simulate click.But not working


#7

sorry i didn’t get what you said


#8

Try putting asterisks (*) around the aaname=‘Work Items’. This worked for me. It appears the selector is different in Chrome than IE for me. Your selector matched my IE selector but in Chrome get

<html app='chrome.exe' title='ACME System 1 - Dashboard' />
<webctrl aaname=' &#x9;&#x9;&#x9;&#x9;&#x9; Work Items' parentid='dashmenu' tag='BUTTON' />

Try this:

<html app='chrome.exe' title='ACME System 1 - Dashboard' />
<webctrl aaname='*Work Items*' parentid='dashmenu' tag='BUTTON' />

#9

It worked.Thanks