Assignment 2: Click 'A https://acme-test.ui...': Cannot find the UI element corresponding to this selector: <webctrl aaname='' tag='A' />

Hello,

I am getting above error when I want to navigate on next page on workItems.
Could you please help me in this?

Thats a problem with your selector, Try repairing it.:slight_smile:

Hi @raginipoman

Go to the activity , wherever there is an selector Error and click : Edit Selector .

image

  1. Click on repair.
  2. Indicate the element again

Thanks,
Mukesh Kala

you can also repair it using UIExplorer.

Thanks
Navneet

I have tried both the options but still getting same error.
I have used 2 dynamic selector in this assignment

  1. " "
  2. “”

in_TranscationItem have String data type

@raginipoman Can you paste the Selector what you have used :sweat_smile:

"

Summary

This text will be hidden

@raginipoman The Whole Selector :sweat_smile:

webctrl aaname=’" + in_TransactionItem + "’ tag=‘A’ / This is 1st selector

html title=‘ACME System 1 - Work Items’ /><webctrl aaname= ‘" + in_TransactionItem + "’ tag=‘SPAN’ class=‘page-numbers current’ / this one is 2nd selector

@raginipoman The First Selector Should have Worked

No… it’s not working… first selctor it self gives error. when I print in_TranscationItem , it contains nothing … but when I have selected item from screen at that time I clicked on page no 2

@raginipoman Did you try with just aaname ?

Thanks all, issue has been resolved now :slightly_smiling_face:

@raginipoman What was the Solution :sweat_smile:

1 Like

Tenho o mesmo problema e os 2 seletores estão como indicado.
Podem me ajudar?