UiPath level 3 Assignment 1 Error


This is where I hit a wall. Solved bunch of errors I got and for the current ones I spent some time in the forum trying to locate the cause of my problem but the fixes I found to the given errors did not end up solved in my case. I believe I have followed the instructions closely in the pdf provided at the assignment and the errors seems simple enough to solve other than the system error I get at initialization, I have no idea what that is.

Since I don’t want to make a mess out of this thread I only added the error messages I got and will provide anything seems necessary by the veterans of the community.

Hi @Ruhat_Sengul,

This occurs when the robot cannot find the UI element with your defined selector. Please make sure that an internet explorer window with title ‘ACME-System1…’ persists on the screen. Also please try the selector <html title='ACME System*' /> . If you are using Internet explorer, make sure the browser type of all the “Attach Browser” activity is IE. If the issue still persists, please share your workflow. :slightly_smiling_face:

Warm regards,
Nimin

can you run the project in debug mode and share with us the variables panel, the activity that caused the object reference? just by the initialization i can say that one of your variable is null because it is not passed right.

1 Like

I watched closely the robot execution while in debug mode and my guess is somehow system close is called twice(or more) and the first one executes successfully, the second one obviously can’t. The first red text in the output is "Attach Browser ‘iexplore.exe ACME’: Cannot find the UI element corresponding to this selector: " and it pops up when I step into System1Close workflow.

@nimin
The problem arises because it seems that I can not have the browser up and running while the System1Close workflow is being executed. The selectors are like you suggested. There is a rather long list of workflows since everything is separated, Which workflows you want to take a look from the list? I cant add more than 1 picture as a new user, adding it on a separate reply.

VARIABLE LIST

This is the variable list that comes while debugging, the snippet i get the error(System1Close) has only 1 variables in it and it is type browser, I set it in attach browser and feed it into close tab. The attach browser has browserType set to IE.

I am also adding the exceptions thrown, I get the second exception 3 times before the crash;

RemoteException wrapping System.NullReferenceException: Object reference not set to an instance of an object. 

at lambda_method(Closure ,
ActivityContext )
at Microsoft.VisualBasic.Activities.VisualBasicValue1.Execute(CodeActivityContext context) at System.Activities.CodeActivity1.InternalExecuteInResolutionContext(CodeActivityContext context)
at System.Activities.Runtime.ActivityExecutor.ExecuteInResolutionContext[T](ActivityInstance parentInstance,
Activity1 expressionActivity) at System.Activities.InArgument1.TryPopulateValue(LocationEnvironment targetEnvironment,
ActivityInstance activityInstance,
ActivityExecutor executor)
at System.Activities.RuntimeArgument.TryPopulateValue(LocationEnvironment targetEnvironment,
ActivityInstance targetActivityInstance,
ActivityExecutor executor,
Object argumentValueOverride,
Location resultLocation,
Boolean skipFastPath)
at System.Activities.ActivityInstance.InternalTryPopulateArgumentValueOrScheduleExpression(RuntimeArgument argument,
Int32 nextArgumentIndex,
ActivityExecutor executor,
IDictionary2 argumentValueOverrides, Location resultLocation, Boolean isDynamicUpdate) at System.Activities.ActivityInstance.ResolveArguments(ActivityExecutor executor, IDictionary2 argumentValueOverrides,
Location resultLocation,
Int32 startIndex)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor,
BookmarkManager bookmarkManager,
Location resultLocation)


RemoteException wrapping UiPath.Core.SelectorNotFoundException: Cannot find the UI element corresponding to this selector: <html title='ACME System 1 - *' />  ---> RemoteException wrapping System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector: <html title='ACME System 1 - *' /> 

at UiPath.UiBrowserClass.Find(String bstrSelector)
at UiPath.Core.Browser.Find(Selector selector,
IPlaceholderResolver placeholderResolver)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context,
IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context,
Bookmark bookmark,
Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context,
Bookmark bookmark,
Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor,
BookmarkManager bookmarkManager)

PROJECT STRUCTURE

ok so let me clarify, your workflow is fine until close system1 window, where u have already closed the window beforehand thats why it crashed?

worst case scenario, in your system1_close workflow add an element exist, assign output to element exist, then add an if, where if element exist, then u do the close workflow, else ignore no steps required. and set element exist timeout to 5 seconds

this should help u solve your issue if you really cannot get IE to run when u execute close.

1 Like

After I created this thread, I continued to try to solve this problem with my own research, tried my luck with “TheBrowser isNot Nothing” in that if statement but element exists feels like another way to go. And it worked! Now i don’t get the fatal error from system close and sha close workflows ^^ In the else statement I am logging a message to see when and how many times it invokes the close workflow. As I suspected it is called twice and my message is getting logged.

Sadly that doesn’t mean I am out of problems to share. I am getting an out argument from extract work items workflow and the rest is as explained in the walk through documentation. Assign the extracted DataTable argument to a DataRow[ ] variable with the given constraints that is in the general business process scope.
TransactionData.Select(“Type=‘WI5’ AND Status=‘Open’”)

But again, for some reason that I am not yet able to understand I am getting an output of type “Trace” - Assign Faulted. The output I am referring is at the very bottom of the output window.

I feel like I might have to start fresh but it feels like taking the easy way out. I also want to be able to see what is wrong with this project so that I can learn from this rather painful process. After the CloseAllApplications workflow being executed the robot does its cleanup, closes general process, main and such workflows and finishes the execution, no warning, no error logged.

your transactiondata datatable variable is null, check where you passed your datatable variable.

and chillax, the community is helpful :smiley:
and honestly don’t follow blindly on what the docs tells u, there are areas you need to look out.

1 Like

Its been a blast struggling with this one but thanks to you I finished it and submitted, the evaluation came back minutes later, got a 100 passing score! I’m glad that a robot gives the score cuz no human being would give that a pass :smiley:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.