Lesson 2 - Practice 1 Walkthrough is not working as per steps

studio

#1

Scenario: Simple flow decision practice not working when we try to build manually as per steps.

Steps to reproduce: Follow the instructions at: https://academy.uipath.com/lms/index.php?r=player&course_id=1#training

Current Behavior: Opens the notepad and does not show “Correct” or “Incorrect” words. It is throwing below error after few seconds.

Simple Flow Decision-manual has thrown an exception

Source: Open application ‘notepad.exe Studio’

Message: Selector not found

Exception Type: COMException

System.Runtime.InteropServices.COMException (0x80040212): Selector not found
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Expected Behavior: Notepad should show default words and should ask for whether to save or discard notepad application.

Studio/Robot/Orchestrator Version:2017.1.6407

Last stable behavior: NA
Last stable version: NA
OS Version: Windows 8.1 (64 bit)
Others if Relevant: (workflow, logs, .net version, service pack, etc): Sample downloaded file in the site working fine. When I have checked the difference between manual steps created by me and system provided XAML file, “Attach Window” is extra in the downloaded file and this step is missing in the tutorial. Please compare both (instructions to create manually in the website and sample file provided for direct download to practice).

https://academy.uipath.com/lms/index.php?r=player&course_id=1#training


#2

Hi @Srinivas_Reddy,

Check if the note pad is opened already. If it is opened, close it and execute the workflow.

Regards,
Rahul


#3

Hello, same thing for me. Does the same even if Notepad is open o closed. I tried to do it myself and thought there was something I was missing. But I downloaded the exercise solution and get the same behaviour. Need help!

imagen


#4

Ok, I finally managed to work it out, so far I saw so little responses about this that could fit my case that I will post it for the non-english versions of the OS.

The problem is located in the ‘Selector’, you must check the string for it may be different depending on your OS language. So that’s why even the downloaded example was not working for me.

So while the example says this for the Open Application activity selector field:
…wnd app=‘notepad.exe’ cls=‘Notepad’ title=‘Untitled - Notepad’ …

my notepad is in spanish and the tittle is different:
…wnd app=‘notepad.exe’ cls=‘Notepad’ title=‘Sin título: Bloc de notas’…

so you must be sure that the selectors have the correct information, don’t trust the examples given in the lessons.

You can also edit the selector and uncheck the tittle info tag or put something like ‘* Bloc de notas’ to avoid the file name.

Cheers!