Level 3 - Advanced Training - UiDemo Walkthrough - Object Issue

Hi, I’m currently doing the Level 3 advanced training trying to follow the UiDemo Walkthrough, however I keep getting this error in my InitAllApplications file:

Invoke Workflow File: Object reference not set to an instance of an object.

I believe I have done everything I was supposed to do but I can not seem to move forward at all.
I’ve created an asset in Orchestrator with the path to the UiDemo.exe file but still get no object reference.

Could anyone please help me?InitAllApplications.xaml (5.7 KB) Config.xlsx (21.5 KB)

The InitAllApplications.xaml file has taken arguments as in_Config. The error occurs when this file is trying to invoke the other file. Check the arguments. The value of in_Config should be in_Config, not just Config. Change the highlighted value to in_Config.

I’ve changed this, but I still get the same error.

Can you send your whole workflow once??

UiPath_REFrameWork_UiDemo.zip (1.7 MB)

Thank you for looking.

Check this workflow,
UiPath_REFrameWork_UiDemo.zip (1.7 MB)
updated one…

Which one did you update? When I run the test workflow file I still get the same error.

This one…

If I run the main file with the updates I now get the error -->
Invoke Workflow File: Could not find file ‘C:\Users\959595\Documents\UiPath_REFrameWork_UiDemo1\UiDemoPath.xaml’.

But UiDemoPath is an asset, that is supposed to store the path to the UIDemo.exe file?

Check your asset value in the orchestrator…

This is my text value

Check your xaml file name in invoke workflow,


It should be as mentioned above.
Now you are getting any errors @Natasha??

Hi,

So I have now changed it to this, but I get the following error:
Open Application ‘UIDemo.exe UiDemo’: Object reference not set to an instance of an object.InitAllApplications.xaml (6.7 KB)

And when I run from the main file I get this:

Invoke Workflow File: The values provided for the root activity’s arguments did not satisfy the root activity’s requirements:
‘UiDemo_Login’: The following keys from the input dictionary do not map to arguments and must be removed: in_Credentail. Please note that argument names are case sensitive.
Parameter name: rootArgumentValues

You have to use the names which you are given in config file.
Even the assest name should be proper.

I have used the same name in the config file: UiDemoPath
Config.xlsx (21.5 KB)

Remove that UiDemoPath from the assest sheet and put it in the settings sheet.

I’ll try sending the whole thing again with the updates I made, but the UiDemoPath asset name seems to match everywhere so I really dont understand.

following this walkthrough:

UiPath_REFrameWork_UiDemo.zip (1.7 MB)

Doing that gave me this error:

Open Application ‘UIDemo.exe UiDemo’: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

As per the above error, the path is not proper @Natasha.
Update your path again in orchestrator.