Lesson 3 practice 1 assign activity

You can’t use row(1).ToString since it is a data row. It should come as row.item(0).ToString and row.item(1).ToString

Now Im getting below error

Are you using For Each Row or just For Each

For Each Row can only used with Data Table. Here ClubMembers is not a DataTable. It is just Array of DataRow.

So you have to use For Each activity only

change the item named as row and Select the TypeArgument to Data Row


Now everything should work fine.

You can get FirstName = row(“First”).toString
FirstName = row.item(0).toString

if this solved please mark the answer as solved.

Till Im getting same error all the changes have done provided by you
unable to upload main.xaml file

you can’t upload mail.xaml file while you are in Studio. Just close the Studio and upload the main.xaml file. Then we can rectify your problem easily.

I have closed stuido then also unable to upload
Can we have anydesk

Issue resolved
thanks a lot buddy

Super. Carry on Buddy :slight_smile:

Hi there,

I have some troubles as well in the lesson 3:

I dont get, how to write the lines out of the extracted members into the Output.
Of course i have tried several ways ( item(0).ToString, item(“Name”).ToString , Change the Argument Type… ) but it wont work.

Whats wrong?

Hi together.
I used to walktrough to “fix” it by myself but as soon as I start the execution of the process the following window pops up:


Does anybody has an idea?

Thank you very much

@zobi can you please share the xaml file here.

i think because you don’t have any data rows in dtClubMember.

just check you select command

it should be like names.Select(“[Club Member] =‘Yes’”)

Here it is.

I think my select-command is correct.

Lesson 3 Practice 1.xaml (10.3 KB)


sorry for late reply.

please check these in your xaml file

  1. names.Select("[Club Member]= Yes ")

    Yes should be come between but you have put

  2. Argument type of For each should be System.Data.DataRow
    but you mentioned array of DataRows, if you change that to System.Data.DataRow it will work fine

It still gives samr error Assign: Cannot find column [‘Yes’].

This is the correct string to use in expression.
names.Select("[Club Member] = ‘Yes’ ")

I am getting the same errors as above.
I put row(“First”).ToString in the firstName variable into Assign activity and getting “Compiler error”.

The variable is defined as String

Hello Guys,

I have same problem in practice 3 :

clubMemebers = names.Select("[Club Member]= ‘Yes’ ")

I need a help :frowning:

i have come across the same issue, can any one help here ?

Sequence5.xaml (7.0 KB)

hi i have come across a similar problem…thanks in advance …Sequence5.xaml (7.0 KB)