Lesson 10 Get Text PDF is not working - Just outputting Ávpageview"

It is really helpful.

Thanks this solution (workaround) works fine form me :slight_smile:

After unchecking “Enable assistive technology support” from Adobe, I had to re-configure the Anchor Base activity to make it work.

I have applied mentioned workaround and changed the settings of Adobe Acrobat Reader preferences but still stuck with ‘AVpageView’ message while using GetText for PDF.
Please help!!.

Hi. I have changed my Adobe settings per the helpful suggestions and turned off my touch screen with no success. Still cannot use Get Text to read specific PDF elements. Please advise on additional. Thanks so much for additional suggestions you may have. k

This is how it worked for me:

  1. Delect first two Edit->Preferences->Accessibility settings. click ok
  2. Go back and now select first two Edit->Preferences->Accessibility settings. click ok
  3. Go to UiPath project and for each Anchor base->Indicate on screen and click on the label. this time notice that it automatically shows a rectangle around the field being selected and you just need to click instead of drawing the rectangle.
  4. repeat for “Get Text” activity.
  5. save and run. It will run flawlessly!

Hi ,
Changed my Adobe settings as per some of the suggestions ,Still cannot use Get Text to read specific PDF elements. Please advise . My pdf sample is like below


I am observing the same and have tried the above solution.

Can anybody help me ?

The above worked for me - awesome thanks !! :smiley:

However I had followed the following steps in the academy training while configuring Adobe Acrobat Reader DC - The first 2 boxes were already checked so I did not do anything. Seems I should have unchecked them and then checked them again:

Note 1: If the PDF is opened with Adobe Reader DC Acrobat, there might be a few steps to take before you can extract specific elements using UiPath studio methods. Start Acrobat and press Ctrl+k. That opens the Preferences pop-up. Select Reading, out of the categories on the left panel. Verify that the drop down Reading Order options is set to the Acrobat recommended option, ‘Infer reading order from document (recommended)’, ‘Page vs. Document’: should be set to ‘Read the entire document’ and ‘Confirm before tagging documents’ should be unchecked. Then on the left panel, click Accessibility. In the Other Accessibility Options section, check the first two boxes if they are not already checked: ‘Use document structure for tab order when no explicit tab order is specified’, ‘Enable assistive technology support’, and click OK.

Hi I have followed thE SAME instructuction it didnt work, Could you guide me a little more on it

@Tanushri Let me explain in a little more detail on the steps.

  1. Open up Adobe Acrobat Reader DC with not document.
  2. Press Ctrl+k to get to following screen and Click on “Reading” to get the following screen:
  3. Makes sure all the settings are the same as on this screen.
  4. Then click on the “Accessibility” option on same screen as in following image:
  5. In the above image you will see the 2 highlighted check boxes.
  6. If any of them are “checked” then you must “uncheck” them BOTH.
  7. Then “check” them both again and click “OK” at the bottom of the screen.

this is nice workaround for this particular lesson task, but it won’t work for real automation as it reaquires checking and un-ckecking accessibility fields each time .pdf document is opened.

I guess it would be better to use OCR image captioning for PDFs instead.


I have tried above PDF settings but no matter which field you select from lesson 10 PDF it always shows “Credit” as text and not the value.

bro i did everything,still there is an issue… when i run my workflow it displays some other value as output

can u explain how u fixed it…please

Sequence4.xaml (7.3 KB)

dear all

the selection area is still to big… can someone help ?


this works :slight_smile:

As usual, the late comer here. Never had the need to work with the PDF activities on my home laptop, until now. And as stated by many folks here, GetText gloriously failed on my machine as well.

I tried all the steps recommended here including changing the settings on the Adobe Reader countless times until… I went back to the Package manager and downgraded from PDF package v 3.3.0, down to v3.1.0.

And then I came back to studio and removed the GetText activity and added it back to the flow. And guess what? It worked! Here is the Highlight test:

And the famouns $40.00 selector in Studio:

I’m now scared to change it back to the latest package and break everything. Can someone confirm if the PDF activity downgrade has something to do with this?


1 Like

Thank you it worked for me :slight_smile: