Jobs stuck on pending even after completion

I have a process that is triggered every 10 minutes. It used to work just fine however, as of late, Orchestrator kept displaying an error stating that there’s already a job pending for the process and I noticed that there’s job stuck on pending, even though there aren’t any running processes and all bots are online AND available.
I’m using on-prem Orchestrator, version 2020.4.1 and I’m not aware of any recent changes that could be triggering this issue.
In order to get things going, I would have to manually Kill or Stop the pending process each time this occurs (which it does at random times).
Please help

Have you tried setting in Trigger Stop Job After options?
After setting this parameter, job removes itself from the list of pending processes.

1 Like

Sorry I forgot to reply. The issue stops after I enabled the trigger. I guess that fixed it. Thank you Adrian

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.