Job Stuck in Pending

I am attempting to run a process I created on a server. However, each time I hit run it gets stuck in pending. The servers UiAssistant is connected to Orchestrator. I see that the “Installed version” says “No Robots” and "Version Status says “N/A”. While the one that does work it says “22.4.4” and “Compliant”. A photo of this is shown below. Any fixes to this problem would be appreciated. Thank you for your time!


It seems you’re not added the robot account!

Please follow the below steps…

1.Tenant->Manage Access->Select your account->Edit->Robot Setup->Run Foreground automation

provide the following


Win+R → TYPE whoami->copy the code and provide it in Domain/Username

Credential store

Orchestrator Database


Your windows password

Credential type

Windows credentials

Then click on save.



I have done that already. When it is stuck in pending it is not pulling the Hostname and the Host Identity says “Pending allocation.” Any other advice?


It’s showing there is no Robots to that account…

Could you please verify that. Are we using the same folder to run the process?

And also check if robots available to that folder


I think I was going about this wrong. I have been trying to make a new template for the server but I have a machine template already created which works with a different hostname. When I run the Hostname as the server with that machine it stays in pending. But if I run it with the Hostname of my current computer it works.

So I am using my machine template that has been working to automatically run the process on my laptop. The server is connected to UiPath Assistant. I can select the hostname of the server when setting up the process to run. Once I do that it gets stuck in pending. So I see their being two possible issues.

 1. I do not have something set up correctly in orchestrator.
    But I have gone through all the tutorials I have seen on how to set up unattended robots 
    and it is set up the same. I have also set up my laptop to work as an unattended user. So I 
    do not think this is the problem.

 2. The second issue I am beginning to think I am running into is that it is that the auto start is 
     being blocked by a firewall. So do you how the computer recieves the request to start 
     running the process. With that I can ensure the command can go through.

Just looking for any advice to fix this problem. I have been looking all over for answers and have been unable to find any solutions. Thank you in advance for you help!

I figured it out the licenses were being assigned the the physical machines (Hostname) and I only had one license that was assigned to my laptop and not the server. So to fix this I had to change the license the the servers Hostname.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.