Java Extensions: "Error #4: Installation failed!"

License type(Free, Trial/License code): Free / Community License

Studio/Robot version: 2018.3.1

Current behavior: Java Extension Installation failed with Error #4, both by triggering the installation from [Studio --> Tools --> Java Extensions] and from command line

Screenshot:

image


Elevated / Administrator Command Prompt --> D:\Users\ckl036\AppData\Local\UiPath\app-18.3.1\UiPath\SetupExtensions.exe /java --> Error #4: Installation failed!


Please help to advise if there is any option to trace the cause of this error. I can see that the below are updated:

C:\Program Files (x86)\Java\jre1.8.0_121\bin\UiPathJavaBridgeV8.dll

C:\Program Files (x86)\Java\jre1.8.0_121\lib\ext\UiPathBridge.jar

Somehow, looks like it is successfully installed with the below command line instead:

D:\Users\ckl036\AppData\Local\UiPath\app-18.3.1\UiPath\JavaSupport\ScreenScrapeJavaSupport.exe /install /jrepath “C:\Program Files (x86)\Java\jre1.8.0_121”

Please help.
Trying to upload the Java extensions from Studio throws the Error #4: Installation failed. It was using parameters: /java /verbose /restart.
I’m trying to start from CMD as UiPath\app-18.3.2\SetupExtensions.exe /java /verbose - same error.
/restart and /jrepath parameters are deprecated.
I have JRE jre1.8.0_181 and java -version is correct.
Thanks in advance,
Oly

hi,
I am getting the same error when trying to install the Java extension.
Can someone assist me on the same? I have got the latest UIPath version 2019.5.0.

I couldn’t see the folder ‘ext’ in the path ‘C:\Program Files (x86)\Java\jre1.8.0_171\bin’. Can someone help me in the installation of Java Extension?

Hi,

can you let me know if this issue resolved? I am facing the similar issue.

Thanks