Issue with type into activity while disconnected RDP

Hello Guys,

I have two Type into activites in one aplication.

First type into - works great even when i dissconnect RDP connection

Second type into - robot stop on that activity and do not type anything. When i connect to RDP it starts to type immediately

So i have the same properties in both activities. One works when RDP is disconnected, and another one not. This is the same aplication. Please advise what can be done here? We do not have Orchestrator.

Hey
you can use Set Text ACtivity in place of Type Into Activity.
please let me it works or Not

Thanks
Rounak

Hi @Add_Bddd

Whether the RDP has a licensed?

Regards
Gokul

Hi,

It have unattended license. It is just not flex so without orchestrator.

And it`s not like whole robot is stoping.

I have created while loop based on get text activity.

while: get text from field is empty - > type into → send mail with get text variable

So bot is working when disconnected im receiveing blank mails -> because type into not working. Once i connect again to RDP -> its is starting to type in the field → i receive mail with my input string.

image

Hi @Add_Bddd

Check the below steps

  1. We should have any on going connections with the VM(bot machine) like user logins. to avoid this we have to restart the VM to make sure that no user logged into this VM machine.
  2. Have you installed the Bot which you are running as un attended from orchestrator by using MSI installer since we must install the bot with service mode since service mode bot is required for un attended automation.

Reference

Regards
Gokul

Thanks Gokul,

I will check if there is ServiceHost. However, everything is working (many automations) just that one type into activity…

And in the same automation:

This not working:
image

And this type into in the same automation is working:

I mean i tried modifying all properties on not working one, trying SimulateType, SendWindowMessages like everything, does not matter. If im dissconnected from RDP it wont type. If i connect it is typing. Basicly have no idea why the first one is able to work and another one not.

HI @Add_Bddd

Have you Tried like this way to use Click activity followed by Type into activity without selector

Regards
Gokul

I don’t, but i will definitely try!

Try like that and let us know about the status @Add_Bddd

Unfortunately i tried above solutions, also ServiceHost is running in process.

When in connected it is writing in field with no problem. No matter what way i will make it type into. Once i discconnect it do not write.

Guys, the solution were changing robot to another PC with license. No change in robot at all, on one it was not working and another PC it is without problems - i dont know what kind of solution it is, and what exactly fix it.