Type into activity not working if the RDP connection closed

I have created the process in that Type into activity is used and it set to run in background by enabling the send window message property

It works as expected, If i starts the process through the Orchestrator in my local desktop and the Process will run in RDP.

Type into activity works only if the RDP is connected, if I disconnect the RDP the specific typeinto activity not working, other activity are working and no error message is also notified


Is your robot license is Unattended?


yes unattented

I used a combination of SendHotkey (Win + Up ) to bring the window up front + Set Focus Activity + Type Into ( with SimulateType set to True, Activate True and ClickBeforeTyping True - not SendWindowsMessages ).
Works perfectly for me in Disconnected RDP mode.

All of the above activities are inside an Attach Browser or Attach window activity.


Can you try with Stimulate instead of SendWindowsMessage?


i will try and let you know

I tried that bit it not working

It’s not working below error has came

UiPath.Core.ElementOperationException: Timeout reached. —> System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

In the marked date field i have to remove the default date and enter empty string.

@Palaniyappan can you please help me to resolve this

1 Like

Hi @Tamilarasanaccet

Instead of type into activity we can use copy paste method

That is

—pass the string or the variable to SET TO CLIPBOARD activity which we mentioned in type into activity
—then use a SEND HOT KEY activity selecting that field as element and with keys as ctrl+v

This will paste the value instead of typing

Pls try this and let know for any queries or clarification



Tried with your solution it’s not working, if RDP is connected means it working as expected but the RDP disconnected means send hot key not working

Hi Tamil,

I just want to know why do you need to disconnect the rdp connection while running the flow?

Normally if rdp disconnected means the server or rdp system screens will be blank. Bit hard to run your process.

It is an unattented automation, the process will be run on server machine at scheduled time

ok. Will you able to fill other fields or only this particular field?

Only particular feild is not updating and other feilds are working as expected.

Only date field, right?

May I know your expected date format values and default date format values?

May I know your expected date format values and default date format values?
Default: current date(today date)
Expected: Need to empty the date feild

Can you give me the format of that values?

Fine then
I would like to know the error we are getting with activity for that specific field

Cheers @Tamilarasanaccet

No error coming, that feild is not typed i think, The issue is only coming while running the process in RDP disconnected mode