Issue With Studio X: Delete Rows Action Not Working With Filtered Data

I have a very simple workflow that seeks to filter an excel table for blank records in a specific column, and then delete them using the Delete Row action. The issue is that the filter action works fine by itself, but when I try to delete the filtered rows I get a runtime error. Conversely, if I do not filter the data and simply run the delete rows action, UiPath deletes all the records from the table just fine.

How can I filter the table AND delete the filtered records. Below is the simple sequence of actions and the error message.

Warm Regards,

Hello @trace.white!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Likely not the best answer, but I believe if you use two separate “Use Excel File” activities, and drop the filter in one and the delete in the other, that should help it run more smoothly.

Thank you for the suggestion. I tried breaking the workflow apart as you suggested. The result was the same as the delete row action failed.
The filter works as desired, but for some reason the delete all visible rows has an issue. Actually trying to use any delete rows option with the filter enabled fails. If I simply delete rows without any filtering, it works.


I’m sorry that didn’t work for you. If its possible to upload your process, or even some screenshots of it with the properties showing for the activities in question, I’d be glad to go over it more and try to help get a resolution.

Yes, let me create a simple process example to upload that recreates the issue.

I believe that I may have discovered the problem which has to do with the number of records in the table being operated on.

Per previous messages, I created a very simple Excel workflow with a five records, some records had data and some did not. I added a filter to select records with no data, and then a delete rows action to delete them. The process worked flawlessly. All blank records were deleted.

I went back to my original dataset (over 6K records) and deleted all but 100 records. The process worked as desired.

A bit of experimentation with record size delivered the following results:

1000 rows = Delete Rows action fail
500 rows = Delete Rows action fail
250 rows = Delete Rows action success

I’ll report this as a bug as I would believe that the action should work regardless of dataset size.

Thank you for taking a look and offering suggestions. The step of creating a simple experiment to recreate the issue was key to approaching the problem from a different angel.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.