Issue authenticating Orchestrator API - Invalid credentials, failed to login

Hey guys,

I’d appreciate some help, have been reading through multiple posts and cannot find a solution of authenticating to the API.

I am using community license for the orchestrator.

I have tried the above solution, with the following code and with a very strange error:
Header req:


Body req:

or
should I be using:
https://cloud.uipath.com/api/account/authenticate
Content-Type: application/json
{
“tenancyName” : “Documentation”,
“usernameOrEmailAddress” : “Documentation”,
“password” : “DocumentationAPItest”
}
which btw, returns (if I use my orchestrator credentials)
{
“message”: “Invalid credentials, failed to login.”,
“errorCode”: 1000,
“resourceIds”: null
}
2nd question if I may:
Also, if I install orchestrator on Premise, would it remove the headache for authentication, or would I need to regenerate such a refresh_token every day?

Thank you for the support.

You have to pass x-UIPATH-OrganizationUnitId in header as well based on new changes in api: check out the following link: https://forum.uipath.com/t/how-to-add-queueitem-using-cloud-orchestrator-api/243590

thanks for the answer.
I tried that, and I get the same response. no improvement there.

Hi @marius.podea

Could you try replacing these:
image

With these:

"

Just a thought…

Hello,
nice catch, this was the issue.
Thank you.

1 Like

I’m glad to hear it worked :slight_smile: I moved your question to a separate topic so that we can mark the correct answer as the solution (this helps other users who arrive at this topic in the future).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.