Is there any way to disable the SSL certifiate in UiPath

Hi Everyone,
I am using http request activity to call an API, I am able to call the main api endpoint , Iam getting the success code 200. but when i call the sub api i am getting the 403 error as the status code. Can anybody tell me how to resolve this issue. Is anybody is having guidelines to how deal with the http and api request using UiPath. I am using UiPath 018.4 enterprise edition.

i am suspecting it might be due to SSL certificate issue, but don’t know , how to deal with this problem

403 is something related to authorization @Shaziya, Can you check if you are passing the credentials correctly?

Can you let me know if you are sending the request of type http or https?

Hi Hareesh, Thank you very much for the quick response,I am trying to access https.

I am trying to hit the main endpoint and able to get the access token , but unable to hit the sub end point, getting 403 error.

As it is a https request, you need to pass the client certificate in the request. Can you try that way @Shaziya?

I am trying to call the api which is present in the same domain. Is it necessary to pass client certificate even if both the client(UiPath) and server(Api) stays in same domain? If yes, from where I should get the Client certificate?

That depends on the server or the authentication configured in the server side. If you are able to send it through postman, it should work in UiPath as well. Can you do the entire request again (exactly as postman) in uipath and check if it is working

Yes, i tried using postman, If i disable ssl certifcate then I am , getting the result , If I enable the SSL certificate, i a m not getting the result. please suggest?

What? Disabling the SSL working? and enabling not working? That was strange @Shaziya

image

Please check if the https proxy is enabled or not

Yes, seems to be strange. I am using system proxy. If I disable ssl certificate then only I am getting the response or else no.

@Shaziya

Try sending the client certificate once in uipath and then let me know if it works. Need to learn a lot it seems :thinking:

@HareeshMR able to get the status code 200, finally issue resolved.

I used to pass the outh token in outh token field of http request activity, when I passed the token using header I was successfully able to hit the api.
Thank you Hareesh for your valuable inputs and helping me in resolving the isssue

Great @Shaziya.

Glad you got the solution