Https Request expired certificate

Hello freinds

i need to make an api call for wich the certificate is expired, right below is the error message obtained

is there any methode to force the api request with expired certificate like we would do in a browser?


try http://url

Hi skini76

Thanks for your suggestion, I tried it, it does not work.
the error message is no longer displayed :
http request : the underlying connection was closed : could not establish trust relationship for the ssl/tls channe
(sorry in the screen shot it apears in french)

But still have the Status Code :0


can you share the link ?

By the link you mean the url ?

the url was provided by one of our customers in order to make a poc, we can only connect to it via OpenVPN connection internally from our company.

Ok, are you able to access this url via browser ? if yes, then you should be able to access it via UiPath.

yes we can access the url via browser by clicking advanced settings then click on continue to the url

This we need to simulate via UiPath…not sure how we can do this…i can’t simulate it here unless you can suggest some website where the certificate has expired.

Would like to know if this is solved ? if so, how ? can u plz let me know ?

We asked the client to update the certificate, it took time but it was the only solution

1 Like