Invoke Workflow File Error 833, 164, 166, 26 is not a valid value for Int32

Scenario: Using a loop & calculations to generate dates and days of week to be processed within Get Transaction Data depending on the requirements met.
No orchestrator, but DataRows used for transation items.

Getting data correctly in Get Transaction Data and the transactions is filled with the correct information. It nicely shows the correct data and number of transactions.

Unable to get it to Process, as I am only getting this error.

Process.xaml - Invoke Workflow File: 833, 164, 166, 26 is not a valid value for Int32. (Parameter ‘value’)

I thought at first it was because I was using a DateTime variable and trying to pass a dd-MM-yyyy hh:mm:ss format, but tried without the space (dd-MM-yyyy) to ensure that wasn’t the problem as I know since earlier that can be a problem.

I have tried it as a string, as a DateTime, DateOnly, but they all cause the same issue. Can’t pass it as an Int32, because that does not work in the process later on.

Any thoughts? Anything would be helpful at this point.

Thinking about the error you are getting, I imagine it is because the value you want to transfer to the Process workflow is not the same type that the workflow expects.

Sharing ss about the error and the argument’s value you are trying to pass to process workflows could be super helpful for better judgment.

Hello Dari,

Our transaction data has two columns, Date and the Day, this is from the Output DataTabel, and that it is transaction 1.

Then as the Data Tabel and Transaction (datarow) goes over to process, it does not actually get “into” the Invoke WorkFlow File in the REFramework.

The only arguments that are being used are the in_TransactionItem and the in_Config. I have tried removing them and recreate them, but it has not helped.

Hi @SJonsson ,

Could you try performing a Debug and Let us know if the Error points to some specific activity or if it is just the Process workflow ?


It is the invoke file that is the problem from what I can find.


Local value of the in_TransactionItem

@SJonsson ,

Could you try deleting the Invoke workflow for Process and Add/Drag the Process xaml again to invoke it newly and configure it accordingly and check if not already done.

Assuming also, you are able to open the Process.xaml file ?

Tried and it doesn’t help.

Yes I can still open and access the process flow without any difficulties

I had been trying to replicate your issue but honestly, I didn’t get it. Anyway, Something that I’m suspicious about the issues is: the system is confusing the date with a number.

Try to reset the format of numbers and dates on your windows. You can do it by following the next steps:
1.- Move to Control Panel
2.- Clock and Region
3.- Region
4.- Additional Settings

I share my configuration just for your review.

Hi @SJonsson ,
Did you have a solution to the problem?

Hello everyone,
I have exactly the same problem and was able to find the cause.
In my process, before starting the Invoke Workflow, I changed the CultureInfo to (de-DE) in order to write an Excel correctly. This led to an error in the subsequent workflow.

If you insert an Assig before the incorrect workflow or after the activity for which you changed it and go back to the default, it should work.

So assign:
Globalization.CultureInfo.CurrentCulture = New CultureInfo(“en-EN”,false)

Best regards, Toni

My solution was to remove the culture info in Get Transaction and only use it in Process.

Thanks @Toni_DE. I solved it by not changing the culture information in Get Transaction, but to leave it as it was until it got to Process. Once there I added the CultureInfo.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.