Selectors No Longer Work & Can't Create New Selectors

Hello,

I’m unsure what has changed on my system, but any ideas would be helpful.

I was developing a patch at the end of the day some time last week. Opening UiPath again the next day, I sought to continue development to find that none of my selectors were validating. I thought it was just a bug and that regenerating the selector would cause it to start working again (I’ve experienced this before), however this was not the case.

Generating a selector (using the “click to select element” tool) would result in an empty string being returned. Using UiExplorer, I noticed that the selector editor window appeared to be in an uninitialized state.


I can select a window and drill down to a particular element in the visual tree, however attempting to build a selector for it is completely nonfunctional.

I have been able to get around this by using a different machine in the mean time, however this is greatly hindering my ability to build and test processes.

In order to try to resolve the issue, I have:

  1. Tried using UiExplorer instead of the standard dialog.
  2. Rebooted.
  3. Attempted a repair on my UiPath install.
  4. Uninstalled UiPath, rebooted, and installed fresh.

This makes me think that this is actually something wrong with Windows itself. I have tried running sfc /scannow, however this did not find any issues.

What should I look at next? Google has been rather unhelpful with this issue.

Hi @Foxtrek_64

Have you tried updating UiAutomation Package!

Regards

HI @Foxtrek_64

Try indicating the selectors by keeping multiple options

image

Regards
Gokul

One by one

Thanks, this worked immediately!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.