Invalid element with Type into and click action

In my workflow, the data is extracted via API call and then typed in a specific [field] search bar. But the problem is that sometimes it’s not typing [or at times it types late] the data but when I checked the log data. It has already been typed (since I get the output value). After type into action, I have click activity and there is an error in that activity as well. (mostly says click generic error).
Sometimes, it says selector not found and sometimes it says uielement no longer valid. How can I solve both issues?

PS: Sometimes it works once (both type into and click button) but since I have these action in loop. It throws error when It changes into next tab after few loops or even in the same tab it throws error


Try using simulate for type into…so that it would be written from backend and might not miss…

And for click try changingthe selector…may be its dynamic …mostly good attributes are tag …type…innertext or value so that the button name does not change and the type and tag also dont change


Well, I have tried everything and it is still not working consistently. BTW i have tried to use both Type into and Click activity inside attach browser and somehow it is working off late. The problem is it’s not working in next tab (the same page of next tab) after I used hot key to go to next tab.


The selectors might be different or there can be multiple possible reasons…to know the cause we need more details to pin point