Installing java extension in the ROBOT machine (Windows server OS 2016)

Hi All ,
am facing difficulty in installing java extension in a robot machine. i tried to use this tool ,
screenscrape java extension. but it gave me , following error. any help would be really useful.
note: running command prompt in the admin mode

1 Like

@loginerror @Pablito @Palaniyappan any help would be really great … any thoughts guys ?

1 Like

Did we try installing from studio
Like close any running Java applications. Launch Studio and access the Tools tab from the Studio Backstage view. The extensions you can install become visible. Click the Java Extensions button. A confirmation message appears, informing you that the extension has been installed.

cheers @karges

1 Like

What version of Windows are you running? On a Windows 10 host I am not seeing an issue with compatibility.

C:\Program Files (x86)\UiPath\Studio\UiPath\JavaSupport>ScreenScrapeJavaSupport.exe /install /default

C:\Program Files (x86)\UiPath\Studio\UiPath\JavaSupport>The extension was installed in all the places where Java installations were found on disk, but some errors occured:

Could not copy over file "C:\Program Files (x86)\Java\jre1.8.0_241\bin\UiPathJavaBridgeV8.dll". It is being used by another process. Retry after closing all java applications.

I was going to try on a Robot only host with Windows 2016, but don’t currently have access to an instance at the moment.

1 Like

its a windows server OS 2016.

1 Like

as i said its a bot machine. we do not install studio over there.

1 Like

hmm, I don’t seem to have a problem installing the extension on Windows Server 2016 1607 b14393.3085.

C:\Program Files (x86)\UiPath\Studio\UiPath\JavaSupport>ScreenScrapeJavaSupport.exe /status

C:\Program Files (x86)\UiPath\Studio\UiPath\JavaSupport>
Installed JREs:
 1. "C:\Program Files\Java\jre1.8.0_221" (System 64-bit JRE)
    JRE details at install time (2020-02-21 09:12:34): JRE version 8, 64-bit
    JRE details (now): JRE version 8, 64-bit
    JRE file status: OK
    JRE JAR files status: OK
    JRE DLL files status: OK
    Cumulative Status: OK
 2. "C:\Program Files (x86)\Java\jre1.8.0_221" (System 32-bit JRE)
    JRE details at install time (2020-02-21 09:12:34): JRE version 8, 32-bit
    JRE details (now): JRE version 8, 32-bit
    JRE file status: OK
    JRE JAR files status: OK
    JRE DLL files status: OK
    Cumulative Status: OK
Total installed JREs: 2 (2 OK)

History of uninstalled JREs:
Total uninstalled JREs: 0

Additional info about System JREs:
  * System 32-bit JRE: "C:\Program Files (x86)\Java\jre1.8.0_221", installed
  * System 64-bit JRE: "C:\Program Files\Java\jre1.8.0_221", installed

Tested using UiPathStudio.msi 2019.10.3 and installed with the following parameters

UiPathStudio.msi ADDLOCAL=Packages,DesktopFeature,RegisterService,Robot,StartupLauncher,JavaBridge,ChromeExtension /qn /l*vx

Some random thoughts

  • Check the properties of the exe (see if it has a file size >0, that it isn’t blocked, etc).
  • Have you tried reinstalling?

i duno what to say about myself! but you were right ! its 0 KB! now what to do ?

is is because of this reason that i was not able to run the setupextensions exe? because that file seems to be fine . but while installing java extension i got #4Error that isthe main reason i switched to this screenscrapejavasupport installation.

1 Like

I would probably uninstall / reinstall the Robot and the extension. If using the MSI add logging so you can see if there are any errors with it.


1 Like

is there a sepreate software to install the extension ? while installing the robot there must be some option to install all the extensions also.

JavaBridge is what should do it for you if you are installing via CLI. Otherwise you can select the JavaBridge option through the UI interface of the installer.

Seems to be a few ways to go about installing it though.

1 Like

but then again the same basic question , as you are well informed about this , you can answer i guess, why first of all the error came " “Error #4: Installation failed” while installting via set up extension .
also one more very basic question , all these extension and stuffs needs to be installed automatically when you install the bot itself right ?

1 Like

I actually don’t have much experience with these extensions other then I’ve tried the Chrome Extension in the past.

I installed the javabridge with the UiPathStudio.msi package. running ScreenScrapeJavaSupport.exe /install was the first time I’ve ran that executable.

The error I received (Could not copy over file "C:\Program Files (x86)\Java\jre1.8.0_241\bin\UiPathJavaBridgeV8.dll". It is being used by another process. Retry after closing all java applications.) indicated to me that the Javabridge was already installed which makes sense as I included it with the msi originally and I had java process loaded in the background so the dll was in use.

You do need to install the extensions that you want to make use of manually or automatically. We have UiPath deployed in AWS and we use a Cloudformation template with metadata / cfn-init to script the installation of a few applications including UiPath Robot and then turned that machine into an image (AMI) and use that image to launch additional hosts when needed already configured except for the registering to Orchestrator.

1 Like

Hi @karges
From where did you take it , I can see a security threat alert on your screen ,
Is this from your virus guard ?

1 Like

3 posts were split to a new topic: How to install Java extension on UiRobot

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.