Input dialog window appears in background


#1

The process I am currently testing includes an input dialog where the user is supposed to enter a date.
Instead of having a standard popup behaviour - the window being on top, focused with the ability to start typing straight away, the dialog window is doing a “pop under”. It is generated, its icon flashes in the taskbar, but it is not on top of all the windows I currently have open.
What do I need to do to avoid this behaviour?

Happens in the most basic sequences with just 1 step - the input dialog


How to proceed input dialog which appears in background?
#2

hi @Cris

which Uipath Version you are using?

With older stable version like 2016.1.6075 we don’t have any option to make it topmost.

But with latest stable release i.e version 2016.2.* in input dialog message activity properties it will be show at topmost
.
checked it and you will be able to see the input box is appearing on top checking it also on newer version i am getting it on top of all screens.

Regards…!!


#3

Thank you for your reply.

I am using a trial version.
The version shown in Start-Help menu is 2016.2.6192 (built one month ago)

Strangely, I am unable to see the option that you mention. Screenshot attached.


#4

hi @Cris

Sorry for miss assumption due to writing confliction you will be find this option in only message box i have mentioned this because in older stable version this was the same issue like input box but in latest version i have not faced such issues.

Input box always will come on top. i guess in .net form input dialog will always come on top because of its default topmost property.

@adrian or @badita anyone? will you please guide us on this?

Regards…!!


#5

I think it’s an issue. We’ll need to test.


#6

I guess this could be relevant information:
Message box with TopMost property activated does appear on top, but it is not focused. I can’t simply press “Enter” to continue, I need to select the popup first.

Using Windows 7 Enterprise edition
Let me know if I can provide further information to troubleshoot this.


#7

Hello again.
While we haven’t done any specific changes, the problem seems to have disappeared on its own.


#8

Hi all,

This is an old thread, but I’m experiencing the same issue with the Input Dialog not being the topmost window. My Studio is 2017.1.6435.

I’ve tested under the following scenarios:

1 - No other windows open; Run workflow; Input Dialog is visible (topmost by default), but not focused.

2 - Multiple other windows open & maximised; Run workflow; Input Dialog is not topmost / visible.

I could possibly workaround with a Parallel to click the Input Dialog window, haven’t tested that yet…

Regards,
Dan


#9

@dlp1980, do you have a workflow or workflows you can share to tinker with?
Regards,
burque505


#10

Same here. I’m on the standard latest Studio version, not on Trial. It would be nice to have a fix.