Image is detectable when using click image but not when using image exist

Hi,

I wanted to click an image as the selector is unable to select.

However, when I using the image exist, it shows false.

But the strange thing is when I using the same image in the click image, the image is able to be clicked.

How is it possible and why does this happened?

Thank you.

Hi @g_ii

Are the image profiling and image accuracy values same in both?

And also is the image loaded when image exists activity is running?

Cheers

Ya both the profiling and image accuracy is the same.

And the image is finished loaded before I check the image exist.
Both the image exist and click image is using the same page (same image) that is finished loaded.

And there are a special things about the element. There are a container in front of the image that I wanted to click. The container causes me unable to select the selector and need to use the image

Hi @g_ii

I hope you did not give any region to search in image exists or the click activity?

And also the selector and image you used are same?

Ideally both use same tech in the backend so it ahpuld not fail unless the webpage is still in loading or the image is not same

Cheers

@g_ii Set wait for ready property as complete in image exists activity
Sometimes image get loaded once all elements in the page got loaded

1 Like

Both the selector and the image used are the same.

In the click and image exist, I just drag the image from the screen and didn’t insert any region. The Clipping region for both activity is empty also.

The application I am sure it is loaded finished as I already opened it for an hour + ald. :thinking:

Hi @g_ii

Is it possible to share the site and the xaml details?

Cheers

The workflow is for an application, thus you are unable to visit it online.

The page contains the table, and when I wanted to click on the table, it will select the whole table, unable to click on the selector. There is an container in front of the element, blocking me to choose the element.
image

I tried to search for the selector in the Visual tree of the UiExplorer. But it also didn’t show there.

Thus, I am using the click image, but before the click image I use the image exist to wait for the loading time.

Although the application is finished loaded, the image exist still return false.

I did test the image exist by opening the app and wait for some times and the result still remains the same.

But then when I test the click image, the mouse is able to went to the click’s location and click it.

Both the image and selector using is the same. In the properties, the similarities also is the same.
The selector is <wnd app='crts.client.main.exe' ctrlname='frmMainForm' />

Hi @g_ii

To start with did you try changing the ui framework from default to active accessibility and tried indicating the element ?

Alternately you can create the selector yourself by inspecting the element on your browser and check the attrributes and tags related to the table

And why do you want to use element exists opposing to increase the timeout property of the click image… and when it fails may be you can have a try catch and catch the error as well

Is the image exists serving as a page transition wait?

Cheers

Changing the UI framework also unable to choose the element.

It’s is a application and I am unable to inspect it, so can’t create the selector myslef.

I did use the try catch and the image show that the interface is finished loaded.

The image exist is not the page transition, It is the element in the table.

1 Like