I'm not able to read PDF correctly

uiautomation

#1

Hello everyone,

This is my first topic and i started with a question hehe. I’m doing the course Trainning Foundation, lesson 10 but when i’m goin to get text from my pdf it just select the content area of my pdf, look:

I already have installed my pdf.activities , what it can be ?


#2

Hi Try get PDF Text or use an ancor to identify the correct data.


#3

Hi, which activity are you using? Or could you attach the workflow file?


#4

Hello, i already tried with anchor base and just identify that area and if i select a region to get text it prints AVPageView


#5

i’m using get text


#6

So it would probably be easier to use the “read PDF text” activity. This will work if the PDF actually has text in it (as in it’s not just an image). It will pull all the text from the file and output it to a variable.

Could you give that a shot and let me know how that goes?


#7

using read pdf text and printing it with message box brings me the text but i want to use get text like in the tutorials :C


#8

Ah sorry, I haven’t gotten to that point in the tutorials. Here’s something that does what you are trying to do.

Main.xaml (8.2 KB)
project.json (287 Bytes)
Lesson_5_Advanced_UI_Interraction_Recap_revamped.pdf (438.4 KB)


#9

hey :slight_smile:

  1. Click “Edit” in Adobe Acrobat Reader DC and choose “Preferences”
  2. In the Preference-window, choose “Page Display” under Categories to the left
  3. At the bottom of the Page there is a section called “Reference XObjects View Mode”. There is an option there called “Show reference xObject targets”. This option is probably not set to “Always”. Set it to “Always” and click ok.
    This solved the problem for someone and this might do the trick for you as well

#10

Thanks @Niket_Ghai ! ! ! this works for me :smiley: