IBM Terminal connection understanding

Hi all,

For terminal integration between UiPath and our AS400 server, until now, I have used IBM System i Access emulator ( .ws extension ), with IBM EHLLAPI as a provider. Everything was working just fine.

But, our IT Infrastructure is planning to disable access through IBM System i Access emulator (apparently IBM does not have new version of System i Access to suport AS400 ?), and they are forcing us to use different approach. I have tried to use other UiPath providers, yet I did not have any success so far.

Do you have any ideas on how to connect UiPath with AS400 IBM, without using System i Access emulator ?

P.S. I have IP adress and port of the terminal, but when I try different provider, I get error: ErrorCreatingTerminalProxy
We have another application called IBM Access Solution, but the extension is (.exe) and IBM EHLLAPI will not work, am I right ?
Thank you.

Hello @Ta_Rik!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @Ta_Rik

Maybe this post will give you some idea:

Otherwise, I’ll tag @DanielaD, maybe she will be able to advise.

Hi @Ta_Rik,

Terminal Activities Package (2.0.0-preview) comes with an enbeded Terminal Emulator (you can configure the connection with Provider “Direct Connection”), so this should solve your issue with System i Access Emulator. Please try it and let us know your feedback.

Thank you,


Hi @DanielaD,

It worked! Thank you so much.
I am interested in this solution, since I have been trying to connect using UiPath internal, but did not find any success. So what has changed with this “Direct Connection” ?

For future reference, this configuration worked for me: TN3270, TELNET, ASCII, Enable SSL/TLS = true.

1 Like

Hi @Ta_Rik,

With the old version of the package, UiPath Internal provider had limited capabilites. The new version of the package comes with a new Terminal Emulator, and we recommend you to use it.


The package is no longer in preview, it was released :

Hi @DanielaD,

I have seen it. The “LU name” option was added in between as well.
Nevertheless, I was hoping you could help me with another issue.

Even though “Direct Connection” works fine on Production instance of IBM server, it does not work on Test one and only thing that I have changed is IP address (since everything else is the same).
After I add Terminal session with right parameters, UiPath launches terminal window and there is just “Disconnected” in bottom right corner.

Is there anything that I could do, some logs or error that occured ?

Thank you.

Hi @Ta_Rik,

You could check Studio logs or try enabling low level tracing Enabling Low Level Tracing .

Since it is AS400, please test also with TN5250.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.