I am totally new to UIPATH and Tried the selector on EDGE for Google search , but it is not working?

I am totally new to UIPATH and Tried the selector on EDGE for Google search , but it is not working ?

Can someone help me please

Can you elaborate what you are trying to do?

Just to write anything in the search input for Google .

Lesson 1 only I am in

Hi, please make sure that the UiPath Extension for Microsoft Edge is installed and try again.

You can check and install it on your UiPath Studio under Tools > UiPath Extensions

The Extention is already installed , but the same issue

First check , if you installed the extension for edge.
Then, you can use recording option from the design ribbon.

From this, you can do multiple activities via recording,once you complete click save.It will add the activities based on your inputs while recording.

You can refer this video for recording:

or you can use open browser activity and in the properties specify the browser and url.
It will open that url in that browser

I am using the Input type , the browser is being intaited , but nothing in the text being typed.

How I can debug to understand why it not being selected ?

use Type into activity

Still cannot I identify the google search to write house of cards

Instead of clicking Run, click Debug. This mode will stop when there is an error. When that happens, take a screenshot and show us the error.

My guess is the selector for the Type Into needs to be edited to make it reliable. Sometimes object properties can change each time a page loads, and you need to use other properties in the selector.

It should be straight forward , Still the first Item Cannot be identified ?? How come

IT is either Giving me Anchor missing or double value found when I am trying to find validate .

Hi @Essam_Fahad,

Try with these settings in your “Use Browser” activity:
2022-10-19 14_30_45-Window
Close: Never
Open: Always or IfNotOpen

This way the browser first open, after it, it will execute the “type into” activity.

Overview activities:
2022-10-19 14_30_19-Window

Kind regards,

You have a popover message appearing on the page with that Save to OneDrive button. Get rid of that.

1 Like

Non of this worked with me , I have changed the Project setting and Everything start working fine . How is that !!!? what is the difference when I switch of the modern design Experince

Hi @Essam_Fahad,

If you switch off Modern Design, u will be using the classic activities, both should work.

Kind regards,