HTTP Request odata/QueueItems(id) queu Item doesn't exists

Hi guys,
I am trying to get a transaction list with ‘odata/QueueItems’. The request works just fine but when I specify the queue ID it gives me a 1002 error.
I am quiet sure the Queue ID is correct as I am getting it with “odata/QueueProcessingRecords/UiPathODataSvc.RetrieveQueuesProcessingStatus” which works just fine.

Any idea why the Queue ID is not recognized?
Many thanks for your time

1 Like

I believe, odata/QueueItems fetches the list of queue items and but not one. So giving a single queue item name as string is not correct. Try sending that one as a list (list containing only 1 queue item name).

Hi Rahul,
Many thanks for your reply.
I followed the logic documented at this site, based on the odata/QueueItems(Id).

The id number in parenthesis (in my cases ‘6’) should give me the detail regarding this specific queue. Unfortunately it shows 1002 error instead, I am positive the queue ID is correct.

Do you happen to have any further suggestion?
Many thanks

Hi @MariPanda,

Can you do below steps on swagger/index.html page itself to fetch queue definitions and see what is the queue if fetched in there?

Upon executing, it would give response something like below for all queues on that orchestrator environment.


Thank you Sonali,
I called the API as advised, I got the same ID I was entering into the system despite it when I call
“odata/QueueItems(id)” >> “odata/QueueItems(12)”
but I am keep receiving the 404 Error.

HI @MariPanda,

Can you try your solution now with this id (12) as I recall earlier you were trying to use queueId as “6” which is why error was being thrown to you as “queue item doesn’t exists”.

I believe you should be able to run the test if you use id as 12 now.

Can you try?


A 404 error means the URL you are trying to reach does not exist.

Hi @sonaliaggarwal47,

I have various queues, I just happened to search for this one ^^
Another thing I noticed is that when I use the general ‘odata/QueueItems’ call, I get the full queue transactions list but the data in is delayed by few hours.
For example when I run my code from 8AM till 5PM and at the end of the day I generate the report using ‘odata/QueueItems’, the report will include only transactions that were processed in the morning. When I run the same code the next day, the report will be full…

Have anyone ever experienced this?

Many thanks!

Thank you @postwick
Indeed, but how come that it happens only when I call a specific queue with ‘odata/QueueItems(id)’ ?
When I use the general version without queue specification ‘odata/QueueItems’ I get the list of all transactions in all queues.

Have you tried it in Swagger to make sure you are passing a correct URL etc?

Hi @postwick,
Thank you for the suggestion, it helped me realize that the ‘id’ in odata/QueueItems(id) stands for the transaction and not for the queue…
Additionally I learned that this function is getting “only” 1000 transactions, so I need to find a different way how to generate the queue report in UiPath. Pity

There is a parameter you can set for how many it returns. Have you looked at the Swagger page? It shows all these things.

Indeed, but unfortunately 1000 is the maximum set by the developers.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.