How to update data in database

Hi everyone,

I’m a newbie and trying to update data in a table - oracle database, my SQL query like this :

“UPDATE RPA_PARA_LOGIN A
SET A.PARA_USER_PASS = @parPass
Where A.PARA_USER_ID = @parUserid;”

and i seted the parameter like this :

and when i try to debug, i get error like this :

can anybody help me please ? :’)

1 Like

i set my connection in other .xaml, and i invoke like this :


when i try select query, it works, but when update query i get error like that…

help me please :frowning:

@alienpluto

Welcome to community

Try without @ symbol, like give parPass, parUserid

Hope this helps you

Thanks

Hello @ksrinu070184 :smiley:,

thank you for ur answer, i tried… but i still get same error :frowning:

Hey @alienpluto Welcome to the community

This video will help you solve your problem: https://youtu.be/RxPYT_ARBsY

Hello @Parth_Doshi,

Thankyou so much for suggestion,

i’ve watched ur video on my first trial to update data from table in database, but still i get that error :frowning:

i saw in that video, you use SQL Server, right ?

is there any different syntax/query in UIPath, between SQL Server Database and PL/SQL or Oracle Database ?

Maybe you or anybody can tell me if i dont know about that :smiley:

Thankyou in advance :slight_smile:

@alienpluto

From the screenshot you provided in previous post, It is showing that password value returns as null, can you check that?

Usually Object reference error will appear if you are passing any null value

Hope this helps you

Thanks

Dear @ksrinu070184,

thanks for ur help…

Finally i solved this problem with change the @ to :
in SQL Server usually use @ for parameter, in oracle db/PLSQL we can use :
and it works :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.