Execute query : Object reference not set to an instance of an object

Hi Team,

I am trying to connect to DB and execute a simple query , I am getting the above error.
I have given screen shots of my .xaml just putting dummy values in server details. Please check and guide me to resolve




1 Like

@Deeipauk Your variable is having null value so you are getting error


you mean the result of the query is empty?

@Deeipauk Can you attach your workflow

DB.xaml (7.9 KB)

@Deeipauk Remove assign actvity ie dt = new Data Table()

1 Like

yes I did, same error…
Now I have only execute query activity

Create one output data table pass dt as input and create one output string variable example output_result and display this in message box

Same Error… Please check screen shot


Can you check your query in database that you are getting result in that

Yes i did, the query is getting executed in DB. I understnd its something to do with mapping DT…

Can you check this query

“select ‘dataid’,‘name’ from ‘ecm_owner.dtreecore’ where name like ‘1257122%’ and subtype=0”

1 Like

Hi Indra, i have removed the query portion just to confirm the oracle conection frm RPA is fine?
I was getting error - Connect : Attempt to load Oracle client libraries threw BadImageFormatException. This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed.

Desc looks like I have installed Oracle client which is 32 bit and I need a 64 bit Oracle client… When I checked my installer it shows I have installed 64 bit only… Could you please give some idea if you know why this issue comes?

1 Like