How to run in unattended mode using image selector in click activity

Hi all

I m using object repository in uipath to click image (Magnifying lens) so its target mapped with image so i couldn’t run in unattended mode(Virtual machine) but its correctly clicked in attended mode. can anybody please help to fix this issue?
image

hi

try to add delay/wait for element to appear activity before indicating the elements
add 1 or 2 seconds
maybe it dont have the time to open the file then identfy the correct element

regards
ahmad

I added 10 sec delay time but i got this error

When run in attended mode its working fine but when i run in unattended mode i got this error.

this is because it cannot find the selector

try
1.add delay before the click img activity ( try 10)
2.add a anchor on the selector or try diffrent framework on selecting the element
3. add wait wor element to appear activity (optional)

when u run from unattended try to monitor the process on the screen ,see if the elemt is present or not

I have checked , when i run in uattended mode, Claim Processing -Electronic Billing screen opened/ appear and it clicked properly with other buttons, check boxs(mapped with out image selector) . Magnifying lens only failed to click by bot.

Actually everything run in unattended mode, im stuck with only magnifying lens( image )click .
I also tried with CV activities its also working fine only in attended mode.

Can anybody give me a solution for this Magnifying lens click?

try to check the element of this button on the virtual machine,
could be the element is diffrent

have u try to add acnhor?
and use fuzzy selector and lower the threshold

regards
ahmad

Yes i added anchor as well and i selected (Croped) particular image only so i couldn’t get the fuzzy selector , its only mapped with image only.

hermn… this is weird,

have u checked the elemt when u try to run on virtual machine?

In CV activities before trying to click, Have you used CV element exists? Does that give you a True value for the Descriptor you have passed?

will CV activities run in unattendedmode ?

Please try to amend the Robot configuration as per the below

Yes, but that should be used in exceptional cases where the normal activities fail to identify the selector. (Resolution changes will effect the CV activities)
Try using Find Element in classic or check app state in Modern activities to see if your selector is valid in Unattended mode.

How do i go there?

Could you share the unattended mode Robot Logs for this error

@divyanancyit
1 Go to Tenant
2 go to Users
3 select the : for your robot
4 Robot Setting

When i run in unattendedmode, i got this error for " Click HoldClaimsMagnifyingLens: Cannot bring the target application in foreground because the Windows session is locked."

So this error only occurs for this particular magnifying icon click & every other click activity is working fine ?
Have you tried using “Simulate Click” , Also I hope you have checked the settings mentioned here