CV Screen Scope / Click image: Timeout reached in unattended mode


I’m new using CV activities on my robot. I’m developing a process that has to click on a certain part of a table in an application with a Print button in one of the cells. Normal clicks are not posible because the selector only takes the whole table and I can’t click on a certain part of it.

I’ve seen that CV click works fine for those cases, so I’ve used the CV Screen Scope on the table and inside this activity I’ve used the CV click on the cell. It works fine in attended mode, but in unattended mode (launching it from Orchestrator) it doesn’t work and returns me the error:

“CV Screen Scope: Timeout reached”

I know that it doesn’t arrive to the click activity, the error is before when it has to take the screen scope of the application.
Some points:

  • I’ve setted the API Key and the URL properties of the acitivity CVScope correctly.
  • I’ve never could use the “click image” activity in unattended mode on other processes because it returns me the same error (timeout reached) even with “SendWindowMessages” property on True.
  • My resolution is 1920x1080. I’ve setted the UiPath.settings with “Logintoconsole” to false, the “ResolutionWidth” to 1920 and the “ResolutionHeight” to 1080.

Somebody can give me help? Maybe solving it I would use the “Click Image” activities in other processes in the future because I think that both problems are related.

Thanks in advance

Hello @informatica1

Is it a web application? Also are you trying to click on some particular text values?

If yes, you can try with click Text activity. If you are not trying to automate a citrix or applications with difficulty to identify the selectors, its always better to try and find out some solution with selector or text rather than using CV or images.


Hi Rahul, thanks for your answer.

It’s not a web application, it’s an application that is connected to Internet but not with a browser.

I’ve also tried to use Click Text activity but it doesn’t detect the text Print…

Will it be possible to share a screenshot of the application?

Yes, but without concrete values:

Will there be always one row in the table and you need to click on some particular position?

There will be always one line, because before clicking on “Print”, I search de invoice number on the field that says “Nº factura”, and for that reason there is only one line.

Sometimes the Print button is on the next cell (just on it’s right side, in the cell that says “Fact. abono”), but this is not a problem because it can be solved with a simple “if”.

So whats the purpose of clicking on the rows in the Table? Are you navigating to the record by clicking on the row?

Or trying to get some data from the table?

Previously the robot makes a Data Scraping of all the table to get the new invoices of the day. After that, it searches the new invoices one by one typing into the field of “Nº Factura” the number of the invoices and clicking on “Pregunta”. It returns the line that you can see in the screen capture of my previous post with the “Print” button/cell. The next step is clicking the “Print” cell and download the invoice.

Ok…So you are facing difficulty in clicking on the Print ryt? And you are not able to inspect on the Print cell?

Did you tried with click image activity?

Yes, but as I said at my first post I always get the error “Timeout reached” when I use this activity in unattended mode. For that I supose that it is related with the “Timeout reached” error of the CV Screen Scope.

The selector to inspect the Print cell with normal click doesn’t work because the selector wraps the whole table, so the only way that I’ve seen to get the concret cell is with CV Screen Scraping and with click image, but both activities work fine in attended mode but not in unattended mode.

I’ve found a way to solve this through normal clicks, but I still want to know if somebody can help me with the problems with CV Scraping and click image…

Add delay before the cv click activity

Done, and it didn’t solved the Timeout reached