How to run Chrome/browser in the background without opening it as a Pop up window ,Using Open browser or use application/browser?

Hi All,

I want to run my automation as an unattended mode, so i dont want browwser/chrome to be opened as a pop on the screen because it will affect the user everytime when the bot is scheduled to run, I have tried with use application/browser activity and enable the Background option also but its not working for me whenever I am running the bot, everytime chrome is opening as a pop over the screen.
How to solve this? is there any alternative way or any other similar browser based application available which allows us not to open it in the foreground in the runtime?


@Ritesh_Burman can you try by following this link

Hi @sangeethaneelavannan1 ,

thanks for the suggession, but it didn’t work for me, actually i dont want that browser pop up window infront of the screen anyhow, Could u please give any hint?


Hi @Ritesh_Burman ,

Unattended mode is running process from orchestrator. Orchestrator will make connection to the bot and if any user is using the machine it will be disconnected so unattended mode is nothing but there is no human intervention needed to run a process.

I think you need background automation so user can do the stuff in the foreground for the background hi automation some extent we can do by using simulate option for all the UiPath activities like click and type into. Simulate option will help us to perform background automation.

please note that if you are running pure background automation like opening excel and doing some calculations in the excel those are would not effect by the user but u automation running in background may effected by the user intervention.

Sharing my thoughts for the question. Thanks


Hi @kirankumar.mahanthi1,

Ok , thanks @kirankumar.mahanthi1 got it . But is it possible to avoid that Google Chrome opening pop up over the screen everytime when we are running the bot because using open browser Activity or using use application/browser wont work for me as it’s always showing that browser pop up for a while ?


Hi @Ritesh_Burman ,

try below option in the use application/browser activity it might helpful. if resize window set to minimize it will force the application to be minimized state so that after running the process browser popup for a second and then it will go to minimized state.

or in open browser(classic activity) also we have similar type of option Hidden to true.

please try both options and let us know. thanks

Hi @kirankumar.mahanthi1 ,

Actually that Hidden option is showing no effect to me for Chrome browser, but that use application/browser that minimize option is working but the problem is that pop up is comming for a second , actually i want to eliminate that pop up completely.


Hello @Ritesh_Burman

If you don’t want even the browser to get opened, then you can go with Headless automation.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.