How to perform https request to web api?

Hi,

How to trigger https request to web api in uipath?
i have installed “UiPath.WebAPI.Activities” package and used “HTTP Request” activity. But this is working only for http request and not https request. how to resolve this?

Just write the endpoints and parameters of the interface

if i give https site (eg: https://11.22.33.1000), will that work?
and
i have given Header, not parameter, is that fine? or should i need to give both?

It will run @vigneshnkv

Check it too

Regards

Nived N :robot:

Happy Automation :slight_smile: :slight_smile:

I have checked with https, it is not working.

if i hit the same in postman, it is working.

I have used the ‘http activity’ extensively with https. Can you post the settings (blurring out sensitive info) in postman compared to uipath? If it works in one then it should work in both, you just have to make sure the settings are the same

One finding i noticed, the issue is with that one particular machine. What could be the reason for issue in machine2?

I have done preview in machine1: (xml is triggered as expected)
image

Machine2 preview (issue, XML not triggering)
image

Is it a different user in machine2? If so, make sure that user is authenticated properly.

Does it work on machine2 if you use soapui or other tools?

yes machine2 is different user. Authentication means? what you are referring here? Please explain.

I cold not check post man tool from machine2 as there is some internal restrictions

Make sure machine2 user is allowed to access that API. This means with simple authentication (username, password), or with integrated/SSO authentication (usually with Active Directory), or other various ways of authentication.

If the authentication method is simple authentication, you could try using machine1’s username and password to validate if the problem is the machine or the user