How to open SAP application


#1

Hi all,

I am trying to open SAP using UIPath but i keep facing the same error: SelectorNotFound

I have tried several methods

  1. using recording
  2. using the Open Application function


Please assist!


#2

Use Start Process activity in that you have to pass file name(file location of SAP app)


#3

you can create shortcut key for the SAPLogon and use that open application…


#4

with that i still keep getting the selector error :frowning:


#5

An error pops up :frowning:


#6

What error you are getting?


#7

i guess you have not enable SAP scripting in both local where robot runs and on the server. it will give direct access to the studio


#8

I got this
image

And subsequently this
image


#9

I got this

image


#10

Your start process activity should be surrounded by Try/Catch block with Exception of type System.Exception


#11

image

what should i set for this?


#12

I use:

Selector: <wnd app='saplogon.exe' cls='#32770' title='SAP Logon 740' />
Filename: “C:\Program Files (x86)\SAP\FrontEnd\SAPgui\saplogon.exe”

Best regards.