Open Application - Cannot identify SAP Window

sap
activities

#1

Hi, I am trying to open SAP Logon using the “Open Application” activity. When I tried to Indicate Window on Screen, UiPath was able to recognize the SAP logon window. However, after I clicked it, there is nothing in the FileName or Selector. Therefore, it looks like that UiPath wasn’t able to identify the SAP after all.

Following the training for SAP, I’ve already set the Scripting parameters as instructed, and although I don’t have authorization to transaction RZ 11, the system administrator has confirmed that the parameter for “sapgui/user_scripting” is set to “True”

I’d appreciate if anyone can give me some insight on how to solve the problem. Thanks.


#2

Hello!

Sometimes when I select the SAP Logon window with the “Open Application” activity it’s doesn’t show the Selector and FileName either. A workaround for this was use the “Start Process” activity and pass the full path of the SAP Logon.

Example:

image

Anyway, updating the Uipath Version was solved the issue for me.

Regards,


#3

Hi Lucas,

Thanks for your response. It is helpful, however, I think what I am getting at is that UiPath is not able to identify/recognize the SAP window and therefore not able to identify any button within that window.

I was able to successfully launch the SAP using the “Start process”, but when I tried to attach the window, I am still getting a blank/null recognition.

What UiPath version are you using now that doesn’t have this problem, by the way?


#4

I’m using Version 2017.1.6435

Are you sure that SAP Scripting is Enable?

Regards,


#5

If scripting will not be Enabled then i guess uipath will prompt something like this. “Something… trying to attach to GUI”.

Here something i am not able to remind :slight_smile:
m i correct? or

Regards…!!
Aksh


#6

Hi,
Please check below post.


#7

Hi ianhyj,

Could you tell me how to download the SAP Logon Application?

Thanks,
Tri