How to escape special character in a column header

activities
custom_activities

#1

Hi all,

I have an excel table with a special characters within the column name. I don’t have any control of the data, so unfortunately i can’t use an alias or modify the data set.

The column is called “Male/Female” (no idea why they haven’t just called it ‘Gender’… but anyways) UiPath throws the error advising that “Male/Female” does not belong to a table. I’ve tried to escape the character using “Male[^ /]Female” and “Male{ / }Female” however no luck.

Any advice?


#2

Hi,
How about use column indexing.(not reliable solution but works :slight_smile: )


#3

Hi,
Thanks for your quick response.
I thought about using the column index but i was just wondering if there was a better way. If there isn’t though, i might just settle… just frustrating though.


#4

just check add header option of read range.


#5

Hi,
I have Header in excel as Country Code * (with Special Character).
getting Error as Cannot find the Column [Country Code *]. please help me Resolving it.


#6

What is the activity are you using?


#7

Hi @gr250154

I managed to resolve my issue by just using the Column index rather than the name. Unfortunately I couldn’t find a way to escape the special characters.

Hope this works for you too