How to disable the Publish button in UiPathX

I’m trying to understand the concept of Citizen Developer and need of restrict the package publishing to orchestrator via UiPathX. I tried the thread
Publish button disabled in Studio .
But still I can publish processes even though my robot type is ‘Attended’. It would be really helpful if anyone can assist me on this.

You can disable publishing to Orchestrator by removing the Package Create permission from the Robot Role or any Tenant roles that you assigned to your Citizen Developer user.

I did that. But still I can see the ‘Publish’ in studioX

Double-check all applied roles for the user.
Then ask you user to Logout and Disconnect from UiPath Assistant and reconnect again.

The button will be Disabled, not hidden.

I had the same issue.

I tried the same as @marian.platonov logout from UiPath Assistant and then login again in Assistant and started UiPath StudioX.
But Publish is not Disabled.

I did logout from UiPath Assistant and reconnected again. Its still the same.
What did you mean by ‘all applied roles for the user’? What are the steps to check that?

It seems that you have some permissions being inherited from a group/role that you didn’t disable for your impacted user.

Check roles and permissions in Tenant → Manage Access

Using /odata/Users/UiPath.Server.Configuration.OData.GetCurrentPermissions in Swagger while you authorize the access_token with the impacted user → Returns a user permission collection containing data about the current user and all the permissions it has.

Note: We have an incoming feature to control the destination of publish via governance but not planned to govern the button itself.

I checked all applied roles for the user and which looks as below

CD Roles is the one which was explicitly assigned with no create permission for Packages.

Do you see any issue with these?

The user is added to a lot of groups. Those groups will have roles, and the roles will have permissions.

Check the approach with /odata/Users/UiPath.Server.Configuration.OData.GetCurrentPermissions in Swagger.

It doesn’t have this Package.Create permission enabled

Does anyone have a solution for my question? @UiPath_Community @UiPathMaster