How to change publish folder path in UiPath

studio
package

#1

Hi,
I want to publish my UiPath Code on my own location path.
Is there any solution how can I do this?

Regards,
Sandy


#2

Hey @Sandy

You can go to this path:

%ProgramData%\UiPath\UiPath.settings

and can change “Uipath.setting” file’s

“NuGetServerUrl”: “%ProgramData%\UiPath\Packages”,

and restart your studio.

Regards…!!
Aksh


#3

Hi @aksh1yadav,

I changed UiPath.setting file but its not working still it using same program data path.

Regards,
Sandy


#4

Hi @Sandy,

By publishing own location path, you mean when you click on Publish from Studio, it should publish in your location machine rather then server or orchestrator?

If Yes, then you just need to right click on UiPath Try icon > Settings > Click Reset.

If no, please let us know, where is the current location it is publishing.

Regards,
V


#5

After messing with Orchestrator for the first time today… I’m confused about where packages go as well.

In the UIPath demo video, it shows pushing the “Publish” button… and their published package somehow lands at myget.org.

Then they go into Orchestrator and somehow it magically knows where the published package is and can use it.

My question:
How do both UIPath Studio and Orchestrator agree upon a location for packages? Shouldn’t this be an easy setting in both GUI? I don’t see anything obvious in either UI Path or Orchestrator which allows us to configure this package location.

Also… why did they publish to myget.org instead of demo.uipath.com (their Orchestrator instance)? What is the best practice? Is this documented in any video or user guide?


#6

Instead of the package being published in “C:\ProgramData\UiPath\Packages” i want to change this location to some other location say “D:\MyNewLocation”.
How can i achieve this ?


#7

You can simply go to %programdata%/UiPath. You will find settings there, you can change the path.
If the robo is connected to orchestrator, the you will see orchestrator path that get’s published.


#8

Change it in UiPath.settings file in %programdata%/UiPath folder


#9

IMO it should be easier to modify this, simply by clicking a button in the UIPath Studio GUI.


#10

How is this done in 2018? It looks like there is no longer a UiPath.Settings file found at %Programdata%\Uipath

Is there a way to change this? It is very inconvenient to disconnect and reconnect studio whenever a package needs to be created. We need to have it available locally so it can be manually uploaded from test --> prod


#11

Hi Dave,

In 2018.1 you can find the UiPath.settings file in %localappdata%\UiPath.


#12

I see the UiStudio.settings there - However, I don’t see the UiPath.settings file?


#13

Sorry for the double post.

It looks like it showed up in %Programdata%\uipath eventually. After install, nothing was there. After first run and activation of Studio, it only had the License folder. After publishing a package, it created a Packages folder. After an unspecified amount of time, it looks like the .settings file just appeared, along with an empty “Projects” folder.


#14

I thought you were using the Community Edition(.exe installer). For the .msi it is in %programdata%.


#15

I’ve learned that the UiPath.settings file shows up after connecting your local robot to an orchestrator.


#16

Hi there !
Version used : 2018.2.3
My robot is disconnected from Orchestrator, I’ve made some modifications in the file %programdata%\UiPath\UiPath.settings as followed:

{
“NuGetApiKey”: “”,
“NuGetServerUrl”: “C:\\temp”,
“ActivitiesFeed”: “”,
“UiPathServerUrl”: “”,
“TracingLevel”: “Verbose”,
“LowLevelTracing”: false,
“SecureLicenseKey”: “”,
“LoginToConsole”: true,
“ResolutionWidth”: 0,
“ResolutionHeight”: 0,
“ResolutionDepth”: 0,
“FontSmoothing”: false,
“ConnectionString”: “”
}

Restart Studio and Robot tray.
Create a dummy project and publish it, but it keeps on publishing to default location (%programdata%\UiPath\Packages)
Also the confirmation popup when publishing, did not show the new location.

I’ve reset settings in Studio, but the UiPath.settings file still unchanged !! It does not rollback to default location.

Can anyone help ? Thanks


#17

Hi,

I think this should apply once you restarted the UiPathRobot Service(from services.msc) after you followed the instruction bellow (looks like you did).

I just retested on on 2018.2.3 (Enterprise) and this still work.
The popup is not showing anymore the destination location.

Note that this approach will be come obsolete as in 2018.3 version, you will be able to provide Custom location when you publish.

Cheers


#18

:+1: I did restart service eventually as a last resort and it took change into account. Thanks !


#19

Hi again !

I’ve been trying to modify location for NuGetServerUrl to a network drive : \\drive\Packages\

But it’s not working : I can’t see the package in the robot tray.

I even try to map the drive to a letter (Z:\Packages) but it’s still not OK…

Changing to a local folder like C:\temp\Packages is working correctly.

I did perform a reboot of service after each changes.

Any ideas how to do it ?

thanks again.


#20

Hyk, Could you please try escaping the slashes?
For example, Let’s say the drive path is \\drive\packages.
Please change them as \\\\drive\\packages