How to Access Google I'm Feeling Lucky From Browser Address Bar

studio
web

#1

I am practicing automation, and found inspiration from this UiPath Challenge to search for the CEO name by its company name.

For practice, I decided to google the company name, then access the first result of Google (and then go to the process to get the CEO name later). I noticed it is much more faster if I accessed it from I’m Feeling Lucky than google it then click the first result.

The problem is, I can’t get to access I’m Feeling Lucky. This I tried:

  1. (Type Into Activity) Type into the address bar “htpps://www.google.co.jp/search?btnI=&q=company-name&source+hp” (yes, I am using Google Japan but i think that’s not a problem).
  2. A bit correction, “htpps://www.google.co.jp/search?btnI=Im+Feeling+Lucky&q=company-name&source+hp”
    (Both failed, so I tried using Windows Shortcut)
  3. (Type Into Activity) Type keyword into address bar, then Shift Enter. Something like “company name[k(shift)][k(enter)]”. Failed. Seems like it doesn’t work if the keyword contains any space. Wanted to try entering keyword with quotes ("") but in UiPath Studio it makes the text loses it’s “”.

Any idea to do this?

*UPDATE: I want to do this possibly not by clicking “I’m Feeling Lucky” Button but by URL or any shortcuts.


How to Deliberately Set Focus on An Application
#2

Hello!

Have you tried to do something like this?

image

1- Open Browser and navigate to Google Japan
2- Type Into what you want on the search bar
3 - Use Click activity to click on “I’m Feeling Luck” button

Hope It helps!

Regards.


#3

Thank you @Lucas.Pimenta for you continuous response, I greatly appreciate it!

I forgot to mention the most important part, that for practice reasons I want to try accessing URL not by any click but by shortcuts, where address bar is accessible via shortcuts (and I’m a bit paranoid I constantly feel shortcuts are far better than clicks if possible).

Any idea to do this not by I’m Feeling Lucky button click?


#4

Hi,
Here we go.
GoogleFeelingLucky.xaml (7.1 KB)


#5

Hello!

We’re facing problems with xaml downloads here on the Forum. Could you please share a screenshot of the flow to help our friend?

Thanks!

Regards,


#6

how about right click and save as.:wink:


#7

Worked. Thanks :smiley:


#8

Exactly what I wanted!
Didn’t think about accessing it from Google Search’s Home Page the navigating it using tabs. Thanks a lot!


#9

Hello I tried the steps but i get error message below.Please help

GoogleFeelingLucky has thrown an exception

Source Type into
Message One or more errors occurred.
Exception Type AggregateException


#10

Does it help when you indicate element on the Type Into Activity?


#11

No it doesn’t work.

I urgently need assistance to automate the process below. Can any one please assist.

I have tried it several times with recording/basic/desktop and web but gets error message.

Develop an automate process which

  1. googles for RPA definition
  2. Put it in an excel file
  3. Email the results to emmanuel.evans855@gmail.com.