How hide Open Browser

Hi,

I’m using open browser activity, i want to hide the browser and get the data. I used hidden option but it is not working. Any other alternative.

what do you mean by hide?
you could just minimize it.

I want to do extract the data with out opening the window (back-end Operations ). Is it possible to extract data with out opening the browser or any other option?

Hi there @vickyms57,
You can use the ‘Hidden’ property within ‘Open Browser’.

However, you will only be able to use API-based interaction, Simulate Type/Simulate Click.

Thanks,
Josh

Hi,
Will Element Exists activity works if we use he ‘Hidden’ property within ‘Open Browser’?

Hi @vickyms57,

Yes, Element Exists may return true and the element hidden also.

Regards,
Arivu

1 Like

Hidden option is not working for Open Browser activity. I’ve used Get text and Element Exists activity in Open Browser.

I have the same problem. I built a sequence with Open Browser and extracted data (did it not hidden to make sure it worked the way I was intending it too), but when I check the box for “Hidden” under Options of the Open Browser activity and then run the workflow again the browser is still visible as the workflow runs. The activities I have inside of the workflow are: type into, send hotkey, build data table, and extract data.

Anyone have troubleshooting tips when the “hidden” configuration does not operate as expected?

Hi @riosjosh

Welcome to our UiPath Forum! :slight_smile:

Could you maybe post some screenshots of your project? It would be worthy to investigate it a bit.

1 Like

Hi @loginerror thanks for the reply. I will do you one better. Attached is my workflow. And before I get a hundred comments sending me to LMGTFY :rofl: this is a training exercise for me, but will need to do something almost identical. This bot works as intended only that I would rather not have the bot searching in Google be shown to the user. AskaDA.zip (1.3 MB)

I am having the same problem when trying to open IE as hidden mode. It just ignores the setting and opens in foreground. Tracking this topic to maybe find a solution

I’m having the same issue.

Hi @BDHolm

Welcome to our UiPath Forum! :slight_smile:

Could you try with the latest UiPath.UiAutomation package? It seems to be working for me on Studio 2019.8.0-beta83 and the latest available stable packages.

1 Like

I am running 2019.4.20. Will the UiPath.UiAutomation package work with it?

Hi @BDHolm

Yes, the Studio version and packages are not depended on each other since they were decoupled in 2018.3 :slight_smile:

I have Studio 2019.10.0-beta.484 and I am facing the same problem.

Hi @Naseer_Ahmed_Khan

Welcome to our UiPath Forum! :slight_smile:

Could you let us know the versions of your packages as per the package manager?

Check the box of “Enable Protected mode” of IE and it should work.

Its working only in IE not in chrome