How do I get Excel to redisplay all hidden columns and remove the applied filter?

I got this error when I tried to use write range.

【error Message】Cannot write to the target range because it has hidden rows. Remove any filters or unhide rows and try again. 【Source】Write Range - "東京"

here is the Excel I used, I want to make those hidden columns reappear and remove filters by RPA, is there any ways to resolve this problems without using send hotkey or keyboard shotcuts…

thank you very much!

Write range 対象Excel.xlsx (469.3 KB)

1 Like

Hi @111962

We can use Excel application scope and a Read range activity where if the option use filter is disbaled it wont take the filter even if it is applied

image

Regards
Gokul

1 Like

Hi

Check with this custom component from UiPath market place

Cheers @111962

1 Like

Hi @111962

To remake the Hidden columns

Refer to this thread

Regards
Gokul

2 Likes

Thank you very much.
I found that this property only shown in excel application scope(read range)
I removed filter by uncheck this property(UseFilter).

1 Like

Thank you very much!
this thread is very helpful. I resolved this problem by using invoke VBA.

Thank you very much.
I didn’t know this HideUnhide activity. I will check this later.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.