How can I pass the file name from app variable to process argument?


I have an app which should be creating an invoice from excel file. It works in studio with filepath.
Now I would like to pass the file path in variable to the process. The program can load the file to and from storagebucket but I guess not in to the process argument.
Should I pass the actual file path as (for example)
C:\Users\OMISTAJA\Pictures\Screenshots or the one which is created when the file is uploaded to storagebucket? Because I only see the one from storagebucket or FileUploader value. I’ll attach a picture here so it can be seen how those are ( I have highlighted the file name).
I have tried with the " " marks in various ways. Now I have “”“” + item + “”“” in my process and before that I also tried those straight to the app in Start Process - Input Override where you enter the variable.
I get the same exception always (in picture) or if I only use the variable without the “” marks the process goes through but it does print only empy “invoices” so I assume it can’t read anything from the file or even find it.
Is there any advice? Greatly appreciated.

Hi Hanne,

Do you have a “Download Storage File” activity in your process? the activity download the file to a desired location. you can then use that location/file to open with Excel.

The path for “Download Storage File” is the storage path. Just the file name if its in root folder or/and with folder name.

Hope that helps.


No I didn’t have and now it’s working!
Thank you so much and have a great weekend!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.