Excel Application Scope Weird Error - Not reading filename from variable

Hi all,

So I’ve hit a very strange problem using excel application scope that I can’t get working. Basically I have a filename in a variable, but when it tries to load into excel it says it can’t find the file and gives me a sequence of characters where the filename should be. I’ve attached a snapshot to illustrate - had to black out some of the details as it’s a client project but the problem is shown. Anyone encountered this before?

Thanks,

Hi @pduffy

Bot is checking the file in the path ..\Invoices\CC959500. But you missed to add the extension of the file, just add the extension and try ..\Invoices\CC959500.xlsx

The filename is as shown “Invoices 101019.xls” but the bot is picking it up as “CC959500”. Please see screenshot where I highlighted and circled.

I tried saving as .xlsx and same problem. In the end I re-created the project in a fresh directory to see if the project got corrupted somehow. After doing this it now picks up the filename but says it’s corrupt (.xlsx version) even though excel has no problems with it. So I’m just working without the excel application scope and this is going ok. But I’ll leave this post here as it’s interested if anyone has encountered it and has an explanation or solution.

@pduffy How do you get the file names?

Passed in as a string argument “in_InvoiceFile”. Please see screenshot.

From where do you get and pass the file name to argument?

I am facing same issue in my project. I am passing the path value from Config file directly to the “Excel Application Scope” activity. I tested that if it picking correct value of path by using message box and it is displaying correct value. But when using same value in excel application scope, it is picking file name as some random numbers.

1 Like