Hostname is not set for Unattended job when running on a different machine

When I created an unattended robot on a different machine and set a time trigger, the host name is not assigned when the job is run. And it’s stuck on Pending status. But when I run the job manually from the assistant, it works fine.

May I know why the hostname is not set when unattended job runs?


Welcome to the community

Did you do the unattended robot setup and given the domain\username and passowrd in the robot on orchestrator?

Is unattended license allocated?

Is robot installed in service mode?


1 Like


Welcome to UiPath forum

I think ur robot is installed in user mode
But it has to be on service mode for running in unattended

There are two modes when we install a robot,

  1. User Mode - The robot will remain online only if the user is logged into the machine (Suitable for attended license)
  2. Service Mode - The robot will also have a service which can be identified from the task manager helping the robot always online to get started once the job is triggered ( Suitable for Un-Attended scenarios)
    This can be done while installing at the beginning just use custom installation and choose service mode.

Would recommend to have a validation in these points as well

  1. robot is properly connected to your Orchestrator or not
  2. Robot is given with correct user name or passwords

Cheers @Maneesha_Ratnadiwakara

1 Like

Thanks for the reply. I think the robot is not set in service mode. Is there a way to change the mode now or do I have to reinstall the bot again?

It’s not in service mode. How do I change this? I’m new to UiPath and just started with it :slight_smile:


Uninstall the current robot and during installation it would ask to seect user mode or service mode …and this option is present in custom installation …

Please go through the doc provided previously for detailed steps


Hi, I have the community version and there isnt an option to chose service or user mode. But there is one to choose from attended and unattended robots. should I select unattended robot mode?


Yes please


Hi I followed the document and created an unattended robot for a user in a different machine. But it still stays as pending when I run the job. (with a trigger as well as manually)

What could be the issue here? Is that a syncing issue or something like that?

I also changed the process a bit and updated the version.


  1. Is the robot installed in service mode in the system?
  2. Licenses is allocated and user details are procided in orchestrator?
  3. Is the machine available or is it shutdown?
  4. Is the user and machine added to the folder where process is present


Thanks for the support. It was a license issue and I got it resolved. :slight_smile:

1 Like